< návrat zpět

MS Excel


Téma: Formát času rss

Zaslal/a 12.5.2013 0:25

Ahojte všichni, potřeboval bych pomoct s převodem času v TextBox1.Text mám napsán text např. 1:56,86 (minut:desítkysekund sekundy,desetiny a setiny sekund) a potřeboval bych ho naformátovat do tvaru sekundy,desetiny a setiny sekund (116,86) tak abych ho mohl dále porovnávat, nemáte nějaký nápad?

Dík moc za radu

Jméno
Kontrola
Text
  b i u s img code url hr   1 2 3 4 5 6 7 8 9 10

Strana:  « předchozí  1 2 3   další »
icon #013307
Poki
No to mate sice pravdu, ze LARGE nevraci poradi (proc by taky mela, kdyz od toho je RANK), ale kdybyste si do bunek vypsal poradi a k nim pouzil funkci LARGE, tak byste videl, ktera hodnota je nejvetsi, ktera je druha nejvetsi...atd (zaroven byste videl, ze nejvetsi je napr. 4 a druha nejvetsi je taky 4 (kdyz by byly tyto hodnoty duplicitni a zaroven maximem mnoziny)

zjistit, jestli hodnota je nebo neni obsazena v oblasti, lze kazdou vyhledavaci funkci, napr. POZVYHLEDAT.
=KDYŽ(JE.CHYBHODN(POZVYHLEDAT(hodnota;oblast;0));0;1) -> pokud hodnota v oblasti je, vrati 1; pokud neni, vrati 0 (standardni hodnoty pro True a False)citovat
icon #013308
Poki
A abyste nerekl, ze jsem nelida, prikladam ukazku, jak poupravit funkci RANK, aby fungovala, jak potrebujete.
Jen upozornim, ze funkce v prvnim radku je jina, nez ostatni:
1. Radek: =RANK(A2;$A$2:$A$8)
2. Radek: =RANK(A3;$A$2:$A$8)+COUNTIF($A$2:$A2;"=" &A3)Od 2. radku je mozne vzorce protahnout dolu...
Příloha: zip13308_rank.zip (4kB, staženo 47x)
citovat
#013309
avatar
Jo dík za ukázku jak bude možnost prostuduju, jen v rychlosti aby byl znám úmysl(musím někam odjet). Pricip vyhodnocení. Popis přílohy.
Pořadí PÚ = pořadí dle neškrknutého úředního času od nejměnší po největší v případě textu je pořadí až na konci (škrknuté časy mám jako text což fce rank přeskakuje aby nenarůstal počet položek)
Pořadí štafeta dvojic: Stejný způsob jako u Pořadí PÚ
Součet: Součet Pořadí PÚ a Pořadí štafety dvojic
Celkové pořadí: Pořadí od nejnižšího součtu, v případě shody součtů rozhoduje nižší Pořadí PÚ.

imgcitovat
#013315
avatar
Takže jsem vymyslel toto
=KDYŽ(COUNTIF($C$2:$C$8;"=" &C4)=1;RANK(C4;$C$2:$C$8;1);100)
jen nevím co napsat místo té 100.
.. A B C D
1 1 3 4 100
2 2 4 6 100
3 3 1 4 100
4 4 2 6 100
5 5 6 11 5
6 6 7 13 7
7 7 5 12 6

Podmínka mě hlídá shodu součtu ale nevím jak se odkázat na porovnání sloupce A pro stejné hodnoty ve sloupci Ccitovat
#013316
avatar
Snad je to tak přehlednější:
.. A+ B= C => D
1.. 1+ 3= 4=> 100
2.. 2+ 4= 6=> 100
3.. 3+ 1= 4=> 100
4.. 4+ 2= 6=> 100
5.. 5+ 6= 11=> 5
6.. 6+ 7= 13=> 7
7.. 7+ 5= 12=> 6citovat
#013324
avatar
Když vynásobím obecnou hodnotu 1:32,98 číslem 86400 v buňce dostanu číslo v sekundách jak psal Opičák, ale tady mě to nefunguje, nevíte jak na to? Vím asi násobím text číslem ale v buňkách mu to nevadilo.

Private Sub UserForm_Initialize()
TextBox1.Text = "1:32,98"
End Sub
Private Sub CommandButton2_Click()
TextBox1.Text = TextBox1.Text * 86400
End Sub
citovat
#013325
avatar
Funguje
TextBox1.Text = Mid(TextBox1.Text, 3, 5) + (Mid(TextBox1.Text, 1, 1) * 60)citovat
#013326
Opičák
Jak psal Pavlus na začátku, jednou z možností je text "rozložit" na číslo před dvojtečkou x 60 a přičíst to co je za dvojtečkou. Jde to třeba takto:
Private Sub CommandButton2_Click()
tx = TextBox1.Value
txt = Split(tx, ":")
cas = (txt(0) * 60) + txt(1)
TextBox1.Text = cas
End Sub

předpokládám, že existuje i jiný způsob, třeba to tu někdo napíše líp.citovat
#013329
avatar
Jo dík za nápad nechal jsem se inspirovat. Nevíte jak použít funkci RANK pro nespojitý výběr? Nějak tak aby to fungovalo, kód je ale špatně.
=RANK(A8;A2 A5 A8;1)Nebo když mám pole Pole(5)=(3,8,4,1,6,7) aby mě vrátilo kolikáté je číslo 3 (v tomto případě výsledek = 2. nejnižší)?citovat
#013330
Opičák
?
Příloha: zip13330_rank_nejvyssicilso.zip (9kB, staženo 39x)
citovat

Strana:  « předchozí  1 2 3   další »

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse