< návrat zpět

MS Excel


Téma: Přepočítávání složitých buňek zpomaluje excel. rss

Zaslal/a 14.9.2013 4:12

Pridal jsem si do souboru excelu nejaky slozity vzorce a hrozne se ted zpomalil. Kdyz upravim jakoukoliv bunku, tak vse zacne prepocitavat, coz trva asi sekundu. Nicmene kdyz to dela pri kazdy zmene bunky, tak se s celym souborem spatne pracuje.
Zkousel jsem presunout ty bunky obsahujici slozity vzorce presunu so jinyho listu, jenze porad to bylo stejne pomaly.

Zapnpout manualni prepocitavani celyho souboru taky neni idealni, protoze chci, aby se vsechny normalni bunky prepocitavali bezne po zmene dat. Idealni by bylo, kdyby se normalni bunky prepocitavali bezne a ty slozity jen na povel. Nebo vsechny ty slozity presunout do jednoho listu a ten celej nejak zamknout.
Jak bych mohl vyresit tenhle problem? Diky.

Zaslat odpověď >

Strana:  1 2   další »
icon #015213
avatar
Kdyz upravim jakoukoliv bunku, tak vse zacne prepocitavat, coz trva asi sekundu.
Toto môže byť spôsobené volatilnými funkciami - chcelo by to nejaký príklad tých vzorcov. Pokiaľ v nich používaš funkcie ako Dnes, Posun, NepriamyOdkaz apod. tak problém je zrejme v nich.citovat
#015214
avatar
=KDYŽ($X2<=DNES();SOUČIN.SKALÁRNÍ(--($A:$A<=$X2);L:L);"")

=SOUČIN.SKALÁRNÍ(--(O:O=R5)*(JE.ČISLO(G:G)))

=SOUČIN.SKALÁRNÍ(--($O:$O=$R5)*(JE.ČISLO($G:$G));L:L)citovat
icon #015215
avatar
Dnes() je volatilná funkcia, pokiaľ ju máš v desiatkach vzorcov, tak sa daná bunka prepočítava pri každej zmene v ktorejkoľvek bunke vo workbooku...

Skús si, pokiaľ potrebuješ porovnávať proti systémovému dátumu, dať tento niekam do premennej v kóde a odtiaľ ju napr. pri otvorení zošitu načítať do nejakej pomocnej bunky a odkazovať potom v bunkách, kde používaš Dnes(), na túto pomocnú bunku...citovat
#015223
avatar
Tak jsem zkusil vsechny dnes() nahradit celkem!$G$1, ve ktery je rucne napsany dnesni datum. Nicmene je to porad pomaly.

EDIT: Ted jsem si ale vsiml, ze pomaly jsou jen ty sloupce, se kteryma pracujou ty slozity funkce ^. Jak jsem psal vejs. Slo by nejak udelat, aby se vsechny ty slozity vzorce prepocitavali jen kdyz potrebuju? S hotnotama vypocitanejma slozityma vzorcema nepracuju casto, zatimco bezny pridavani dat ro radku delam casto.citovat
icon #015225
avatar
Tých príčin môže byť mnoho, ich odstraňovanie je metóda pokusov a omylov. Skús preveriť používané oblasti jednotlivých listov, všetko ostatné premazať, skontroluj v správcovi názvov (Name manager) pomenované oblasti a chybné odstráň. Častou príčinou pomalosti je extenzívne používanie podmienených formátov. Ako hovorím, príčin môže byť mnoho. Môžeš skúsiť súbor list po liste skopírovať do nového súboru, to tiež niekedy zafunguje. Inak neviem, ten súbor pred sebou nemám, tak len hádam...citovat
icon #015227
avatar
Slo by nejak udelat, aby se vsechny ty slozity vzorce prepocitavali jen kdyz potrebuju?

To netuším, či sa dá takto niekde nastaviť.

Možno by pomohlo tie zložité funkcie zapísať cez pomenovaný vzorec, ale to by sa muselo vyskúšať, to pálim naslepo..

edit: každopádne, pokiaľ dokážeš obmedziť oblasti, na ktoré sa odkazujú tie skalárne súčiny tak, aby nevyhodnocovali celé stĺpce, ale len oblasti, v ktorých sú dáta, tak to by zrýchlenie prepočtu, a nie malé, samozrejme prinieslo...citovat
#015228
avatar
Omezovani ty oblasti to taky nezrychlilo. Nicmene vsechny ty slozity vrozce jsem dal do jednoho listu, nechal jsem jen prvni radek a dnes nahradil staticky napsanym datem. Kdyz budu potrebovat, vyplnim si bunku dnes a pomoci automatickyho doplneni ten prvni radek slozitych vzorcu dosacne roztahnu az dolu. Diky za rady.citovat
icon #015259
eLCHa
Důležité je nemít vzorce tam, kde můžou být konstanty

Pokud máte takovýto list, vypněte v něm automatické výpočty a přepočítávejte po stisku F9 (musíte na to ale pamatovat)citovat
#015270
avatar
Jak to udelam pro jeden konkretni list? Umim to nastavit jen pro celej excel.citovat
icon #015271
eLCHa
Špatná formulace - omlouvám se

samozřejmě, že tu volbu vypnete pro všechny sešity

Můžete si ta nastavení vytáhnout jako já na panel nástrojů Rychlý přístup a tak je budete mít vždy při ruce a ve chvíli zadávaní prostě vypnete, skončíte a zapnete. Navíc vždy hned vidíte, jak to máte nastavené
Příloha: jpg15271_kalkulace.jpg (24kB, staženo 75x)
15271_kalkulace.jpg
citovat

Strana:  1 2   další »

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Současné rozplánování více projektů v Excelu.

exceleda • 3.3. 17:46

Současné rozplánování více projektů v Excelu.

eLCHa • 2.3. 22:03

Oddělovač polí

Milan-158 • 1.3. 16:01

Oddělovač polí

Whooocak • 1.3. 15:14

Vkládání dat z formuláře na zamknutém listu.

Milan-158 • 1.3. 15:12

Vlastne planovanie zmien

Anonym • 1.3. 7:56

Vkládání dat z formuláře na zamknutém listu.

Začátečník • 28.2. 19:34