< návrat zpět

MS Excel


Téma: Vyhladanie opakujucich sa znakov rss

Zaslal/a 28.3.2014 9:52

Ahoj, snazim sa riesit poziadavku na hladanie buniek v stplci kde sa opakuje 2 a viackrat jeden znak zasebou s tym ze iny znak tam nie je : napr : 00, aaaaa, 444444444
ale neviem ako to spravit kedze cez klasicke filtre to neviem spravit

stop Uzamčeno - nelze přidávat nové příspěvky.

#018550
avatar
nasiel som riesenie:

=IF(LEN(A1)>1;REPT(LEFT(A1;1);LEN(A1))=A1)

len oprava :) (ciarky som vymenil za ";" )citovat
#018556
avatar
jenom kdybys měl CZ Excel tak je to:

=KDYŽ(DÉLKA(A1)>1;OPAKOVAT(ZLEVA(A1;1);DÉLKA(A1))=A1)

jinak mayor díky asi taky někdy využiju 1citovat
#018563
avatar
a este pridam drobnu upravu, kedze som zistil ze dany vzorec mi robil problemy pri ciselnych hodnotach :

=CHOOSE(IF(ISNUMBER(A1*1);2;1);IF(LEN(A1)>1;REPT(LEFT(A1;1);LEN(A1))=A1;FALSE());IF(LEN(A1)>1;(REPT(LEFT(A1;1);LEN(A1)))*1=A1;FALSE()))citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Spustit makro v určitý čas

Baja • 28.11. 20:11

Spustit makro v určitý čas

elninoslov • 28.11. 17:09

Spustit makro v určitý čas

Baja • 28.11. 12:51

Spustit makro v určitý čas

elninoslov • 28.11. 0:31

Spustit makro v určitý čas

Baja • 27.11. 22:22

Spustit makro v určitý čas

Anonym • 27.11. 22:20

Spustit makro v určitý čas

elninoslov • 27.11. 21:11