< návrat zpět

MS Excel


Téma: Vyhladanie opakujucich sa znakov rss

Zaslal/a 28.3.2014 9:52

Ahoj, snazim sa riesit poziadavku na hladanie buniek v stplci kde sa opakuje 2 a viackrat jeden znak zasebou s tym ze iny znak tam nie je : napr : 00, aaaaa, 444444444
ale neviem ako to spravit kedze cez klasicke filtre to neviem spravit

stop Uzamčeno - nelze přidávat nové příspěvky.

#018550
avatar
nasiel som riesenie:

=IF(LEN(A1)>1;REPT(LEFT(A1;1);LEN(A1))=A1)

len oprava :) (ciarky som vymenil za ";" )citovat
#018556
avatar
jenom kdybys měl CZ Excel tak je to:

=KDYŽ(DÉLKA(A1)>1;OPAKOVAT(ZLEVA(A1;1);DÉLKA(A1))=A1)

jinak mayor díky asi taky někdy využiju 1citovat
#018563
avatar
a este pridam drobnu upravu, kedze som zistil ze dany vzorec mi robil problemy pri ciselnych hodnotach :

=CHOOSE(IF(ISNUMBER(A1*1);2;1);IF(LEN(A1)>1;REPT(LEFT(A1;1);LEN(A1))=A1;FALSE());IF(LEN(A1)>1;(REPT(LEFT(A1;1);LEN(A1)))*1=A1;FALSE()))citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Sumar nakupov

Pavlus • 22.1. 13:05

VBA - načtení dat ze souboru s proměnným názvem

Fantasyk • 22.1. 9:12

Sumar nakupov

Robo11 • 21.1. 21:23

VBA - načtení dat ze souboru s proměnným názvem

€Ł мσşqμΐτσ • 21.1. 12:21

Tělo emailu ve VBA - formát

Fantasyk • 20.1. 20:47

odstranenie opakujucich sa udajov v riadkoch

frantilopa • 20.1. 18:12

odstranenie opakujucich sa udajov v riadkoch

marjankaj • 20.1. 18:01