< návrat zpět

MS Excel


Téma: Zjištění počtu obsazených buněk v určité oblasti rss

Zaslal/a 14.8.2014 8:42

Ahoj všem,

potřeboval bych poradit, zda existuje nějaká jiná funkce na zjištění obsazenosti buněk než COUNTIF(S), jelikož mám oblast větší než 127 buněk konkrétně oblast A9:AJ123. Nebo je nutné udělat makro? Pokud ano, věděl by někdo jak co nejjednodušeji na něj? Výsledek bude počet buněk, ve kterých je jakákoliv číselná hodnota i "0", pouze pokud je buňka prázdná nepočítá se.

Díky moc Pee 1

Zaslat odpověď >

#021119
Opičák
a text ?
tento vzorec spočítá počet obsazených buněk
=SUMA((data<>"")*1) - maticový
oblast buněk pojmenovaná "data"

ale lze samozřejmě použít i
=COUNTIF(data;"<>"&"")citovat
#021121
avatar
skusal som funkciu COUNTIF na ten range a funguje spravne

... prilozte prilohu tam bude asi ina chyba
Příloha: zip21121_pokus.zip (6kB, staženo 21x)
citovat
#021125
avatar
Ahoj,

zkusím tu SUMU, ale ten COUNTIF mi opravdu nefunguje, zasílám přílohu, tak třeba tam dělám opravdu nějakou chybu. Někde jsem četl, že má oblast omezení na 127.

No hádat se nebudu, jelikož jsem ještě excel looser 1
Příloha: rar21125_rozsah.rar (21kB, staženo 27x)
citovat
icon #021128
eLCHa
Máte tam cyklický odkaz v buňce E12citovat
#021129
avatar
to eLCHa ... moc děkuji!!

Všiml jsem si, že mi tam skáče hlášení s cyklickým vzorcem, ale nemohl jsem ho najít 8 ... a nenapadlo mě, že COUNTIF na tom selže. Čekal jsem, že ho maximálně bude ignorovat.
A nevíte jak je to s tím limitem? Asi jsem to nepochopil, jestli to náhodou není u COUNTIFS a to omezení je na počet oblastí?

Ještě jednou moc díky všem!!citovat
icon #021130
eLCHa
@Pee
Limitu se bát nemusíte.
Cyklický odkaz musíte řešit, přes to vlak nejede. Dole ve stavovém řádku vlevo máte napsáno, kde je.citovat
#021135
avatar
to eLCHaZas: o kousek chytřejší 3

Ještě jednou díky moc Všem za pomoc! 1citovat
#050595
avatar
Šel bych cestou funkce SUBTOTAL, je potřeba se tam podívat co se hledá, třeba já si vyhledatl SUBTOTAL(103;A1:AJ127) a spočítá to obsazené i volné buňky. Ověřit to lze výběrem buňek, kde se v dolní liště vypíše počet buňěk. 10citovat
#050601
avatar
Nestačilo by

=POČET(E9:AJ123)
pro čísla

=POČET2(E9:AJ123)
pro neprázdné buňky?citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

Najít data

Jiří497 • 12.5. 0:58

import xml dat do sešitu včetně označení sloupců

elninoslov • 12.5. 0:46

Najít data

elninoslov • 12.5. 0:40

Najít data

vikizaj • 11.5. 23:41

import xml dat do sešitu včetně označení sloupců

MilaF • 11.5. 23:20

VBA - automaticky posouvat vzorec v KT

Fantasyk • 11.5. 20:25

import xml dat do sešitu včetně označení sloupců

elninoslov • 11.5. 16:47