< návrat zpět

MS Excel


Téma: Countif se zástupným znakem rss

Zaslal/a 25.9.2014 13:27

Ahoj, prosím o radu. Mám v Excelu x hodnot v seznamu. Potřebuji pomocí funkce countif zjistit počet hodnot vydefinovaných pomocí první číslice. Např. by otázka mohla znít, kolik hodnot začínajících číslem 2 se nachází v seznamu.Zkoušel jsem

=COUNTIF(oblast;"2*")

a různé další varianty, ale nic nešlo. Díky za radu.

Zaslat odpověď >

icon #021658
avatar
ad rôzne varianty, napr. takto to funguje:
=SUMPRODUCT(--(LEFT(oblast; 1)="2"))citovat
#021659
avatar
Ve funkci COUNTIF nemůžeš porovnávat číslo as textem (můžeš, ale ke konverzi dochází jen někdy).

Zkus něco jako

=SUMA(1*(ZLEVA(oblast)="2"))

Ulož jako maticový vzorec (ctrl-shift-enter)citovat
#021660
avatar
OK, díky takto je to OKcitovat
#021662
avatar
....ještě jeden dotaz. Chtěl-li bych, aby to fungovalo i při filtru, tzn. něco jako funguje =SUBTOTAL(109;oblast) a pak filtrem zvolím jen nějaké řádky. Lze to použít ve zmíněných funkcích?citovat
#021663
avatar
Nelze.

asi nejjednodušší bude do pomocného sloupce napsat --(ZLEVA(A1)="2")
a použít subtotal na pomocný sloupce/sloupcecitovat
#021664
avatar
A lze.
Len si musíš upraviť formát stlpca A. Trocha sa s tým musíš pohrať.
Příloha: zip21664_aide.zip (7kB, staženo 13x)
citovat
#021672
avatar
Tak tedy lze, ale k použití nedoporučuji a vysvětlovat nebudu:

=SUMA(--(ZLEVA(A1:B10;1)="2")*(SUBTOTAL(102;POSUN(A1:B10;ŘÁDEK(A1:B10)-1;0;1;1))>0))

(maticový vzorec)citovat
#021673
avatar
Vynechal jsem sloupec..

=SUMA(--(ZLEVA(A1:B10;1)="2")*(SUBTOTAL(102;POSUN(A1:B10;ŘÁDEK(A1:B10)-1;SLOUPEC(A1:B10)-1;1;1))>0))citovat
#021674
avatar
OK. Díky za rady.

Tomášcitovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse