< návrat zpět

MS Excel


Téma: Podmínky na výpočet tabulky rss

Zaslal/a 15.1.2015 12:22

Ahoj, prosím o pomoc s následujícím viz příloha:
Pokud se v buňce B2 objeví hodnota PPZ, OSVC nebo ELKP tak vypočti rozdíl sloupce Aprobation a Correction ( výsledek musí být vždy kladné číslo) a pokud je tento rozdíl menší než 500 vepiš do sloupce "Info" OK a pokud je větší než 500 napiš do sloupce "Info" Vykřičník nebo NO.
Pokud se v buňce B2 objeví jiná hodnota než výše uvedené nech D6 prázdnou.

Děkuju

Příloha: zip23153_podminky.zip (7kB, staženo 20x)
Zaslat odpověď >

#023154
avatar
=KDYŽ(NEBO($B$2="PPZ";$B$2="OSVC";$B$2="ELKP");KDYŽ(KDYŽ((B10-C10)<0;(B10-C10)*-1;B10-C10)<500;"OK";"NO");"")

při rozdílu přesně 500 se objeví NO ale to už si dokážeš jistě ošetřit v případě potřeby 10citovat
#023155
avatar
Je to úplně super a prosím ještě: když budu chtít zapsat do sloupce Info ne Ok nebo No, ale ten rozdíl těch dvou sloupců ( samozřejmě kladné číslo) tak jak to doplnit. Děkuju. MArekcitovat
#023156
avatar
Ještě sem zapomněl dodat k mé předchozí reakci, pokud bude nějaký z řádků ať už ve sloupci Aprobation nebo correction prázdný ( nebude tam ani nula) tak nic nevypisovat to sloupce Info. Děkuju Marekcitovat
#023161
avatar
No, myslím si že pokud prozkoumáte vzorec,tak zjistíte jak je ošetřeno záporné číslo i ono OK nebo NO.
A pokud se prázdných sloupců Aprobation nebo Correction týká tak jste si svým způsobem hodně odpověděl už v otázce 10
pokud=KDYŽ bude nějaký z řádků ať už ve sloupci Aprobation nebo=NEBO correction prázdný ( nebude tam ani nula) tak nic nevypisovat to sloupce Info.


tak to ještě zkustecitovat
#023163
avatar
Vzorec je mi obsahově celkem jasný, první věc jsem vyřešil,
=KDYŽ(NEBO($B$2="PPZ";$B$2="OSVC";$B$2="ELKP");KDYŽ((B6-C6)<0;(B6-C6)*-1;(B6-C6));"")

ale nevím jak korektně zapsat druhou věc: pokud=KDYŽ bude nějaký z řádků ať už ve sloupci Aprobation nebo=NEBO correction prázdný ( nebude tam ani nula) tak nic nevypisovat to sloupce Info.citovat
#023164
avatar
pro D6 =KDYŽ(NEBO(B6="";C6="");"";KDYŽ(NEBO($B$2="PPZ";$B$2="OSVC";$B$2="ELKP");KDYŽ(KDYŽ((B6-C6)<0;(B6-C6)*-1;B6-C6)<500;"OK";"NO");""))

to OK nebo NO si dořešte dle vaší potřeby já to z příspěvku nějak moc nepobral 10citovat
icon #023168
eLCHa
Pokud má někdo rád zajímavé (nebo aspoň netradiční) řešení jako já - tak mně napadlo využít funkci HODNOTA.NA.TEXT=HODNOTA.NA.TEXT(B6-C6;"[>500]""NO"";[<0]"""";""OK""")=TEXT(B6-C6,"[>500]""NO"";[<0]"""";""OK""")je to poněkud kratší zápis (a mně přijde i přehlednější) ;))

Stejně tak seznam položek, pokud bychom ho nechtěli dát do oblasti, lze zkontrolovat takto=COUNTIF($B$2;{"PPZ";"OSVC";"ELKP"})>0Je ovšem zajímavé, že i když mi tento výraz vrátí hodnotu PRAVDA, takA(COUNTIF($B$2;{"PPZ";"OSVC";"ELKP"})>0;PRAVDA)vrací špatně NEPRAVDA (mno, asi nemůžu chtít všechno ;))) ).

Celý vzorec pro tento případ=KDYŽ(NEBO(B6="";C6="");"";KDYŽ(COUNTIF($B$2;{"PPZ";"OSVC";"ELKP"})>0;HODNOTA.NA.TEXT(B6-C6;"[>500]""NO"";[<0]"""";""OK""");""))=IF(OR(B6="",C6=""),"",IF(COUNTIF($B$2,{"PPZ","OSVC","ELKP"})>0,TEXT(B6-C6,"[>500]""NO"";[<0]"""";""OK"""),""))citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Sumar nakupov

Pavlus • 22.1. 13:05

VBA - načtení dat ze souboru s proměnným názvem

Fantasyk • 22.1. 9:12

Sumar nakupov

Robo11 • 21.1. 21:23

VBA - načtení dat ze souboru s proměnným názvem

€Ł мσşqμΐτσ • 21.1. 12:21

Tělo emailu ve VBA - formát

Fantasyk • 20.1. 20:47

odstranenie opakujucich sa udajov v riadkoch

frantilopa • 20.1. 18:12

odstranenie opakujucich sa udajov v riadkoch

marjankaj • 20.1. 18:01