< návrat zpět

MS Excel


Téma: Podmíněné formátování dle hodnoty rss

Zaslal/a 6.2.2015 21:58

Dobrý den,
v buňkách B1:B10 jsou hodnoty 1-10 - nemusí být posloupně, ale např. hodnota 1 se může vyskytovat v kterékoli buňce od B1 do B10. Potřebuji, aby buňka A1 se zformátovala, pokud se v kterékoli buňce v rozsahu B1-B10 objeví hodnota 1. Když použiju v podmínce vzorec =$B$1:$B$10="1", tak se buňka A1 zbarví pouze pokud je hodnota 1 v buňce B1, pokud je jinde, nic se neděje. Předem díky za jakoukoli radu.

Zaslat odpověď >

#023516
avatar
např: COUNTIF()citovat
#023517
avatar
Do buňky A1 nastavit podmíněné formátování podle vzorce =KDYŽ(NEBO($B$1=1;$B$2=1;$B$3=1;$B$4=1;$B$5=1;$B$6=1;$B$7=1;$B$8=1;$B$9=1;$B$10=1);1;0)citovat
#023518
avatar
Na menším monitoru nemusí být vidět celý vzorec, raději přikládám přílohu.
Příloha: zip23518_podmformat.zip (5kB, staženo 22x)
citovat
#023520
avatar

chey napsal/a:

Do buňky A1 nastavit podmíněné formátování podle vzorce =KDYŽ(NEBO($B$1=1;$B$2=1;$B$3=1;$B$4=1;$B$5=1;$B$6=1;$B$7=1;$B$8=1;$B$9=1;$B$10=1);1;0)

A vedel by si to napísať aj pre bunky B1:B10000 ? 2citovat
#023522
avatar
Možná na větším monitoru.
Na malém buď=COUNTIF(B1:B10;1)>0nebo=SUMA((B1:B10=1)/1)>0citovat
icon #023524
avatar
@chey
Budeš zrejme milý chlapec ochotný pomôcť, ale je to trocha neúcta, ukázať tú hrôzu po tom, čo sem dá kp57 omnoho lepší návrh, nemyslíš? Je to tvoja vec, pmn však v tomto prípade robíš zo seba ...
Cez NEBO to samozrejme ide tiež, akurát by to v tom prípade, aby to bolo použiteľné, malo vyzerať nejako nasledovne:=OR($B$1:$B$10=1)
@kp57
len technická: podmienka platí, pokiaľ jej výsledok je PRAVDA (t.j. > 0), z toho plynie, že > 0 vo vzorci je už v podstate nadbytočné, stačí prosté:=SUM(--($B$1:$B$10=1))alternatívne:=COUNTIF($B$1:$B$10;1)citovat
#023527
avatar
Jojo, člověk se musí pořád učit.
To jsem netušil, že v Podmíněném Formátu libovolné číslo různé od nuly vrátí PRAVDA.
Měl jsem vždy za to, že vztah "PRAVDA=1" platí explicitně a oboustranně. Díky AL.citovat
icon #023529
eLCHa
@Al - jen technická ;)))

AL napsal/a:

@kp57
len technická: podmienka platí, pokiaľ jej výsledok je PRAVDA (t.j. > 0)
patří tam
t.j. <> 0

když do B1 dáte =KDYŽ(A1;1;0)
pak výsledek bude 0 pouze pokud v A1 bude přesně 0 nebo bude prázdná
-1 => PRAVDA

stejně tak ve VBA, (pouze s rozdílem, že CLng(True)=-1)citovat
icon #023531
avatar
@eLCHa
jj máte pravdu, ďakujem za upresneniecitovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Sumar nakupov

Pavlus • 22.1. 13:05

VBA - načtení dat ze souboru s proměnným názvem

Fantasyk • 22.1. 9:12

Sumar nakupov

Robo11 • 21.1. 21:23

VBA - načtení dat ze souboru s proměnným názvem

€Ł мσşqμΐτσ • 21.1. 12:21

Tělo emailu ve VBA - formát

Fantasyk • 20.1. 20:47

odstranenie opakujucich sa udajov v riadkoch

frantilopa • 20.1. 18:12

odstranenie opakujucich sa udajov v riadkoch

marjankaj • 20.1. 18:01