< návrat zpět

MS Excel


Téma: Kontingenční tabulka z více listů rss

Zaslal/a 12.10.2015 16:10

AlfanDobrý den všem,

potřeboval bych poradit s konti tabulkou z více listů.
Na každém listu mám splátkový kalendář. Splátkové kalendáře budou ve stejné struktuře, akorát se mohou lišit počty řádků (počet splátek).
Samozřejmě, že bych mohl dávat ta data pod sebe na jeden list, ale to se mi nechce a chci mít každý splátkový kalendář na samostatném listu.
Pokud mám použít Tabulku pro každý splátkový kalendář, není problém.
Nicméně já bych potřeboval v té konti tabulce vidět:
Za každý rok a předmět výši úroků v anuitě a případně si to vyfiltrovat i za každý měsíc.

Použil jsem Průvodce konti tabulkou, ale nepodařilo se mi do Filtru dát "Rok" a "Měsíc".

Mohl byste mi někdo poradit.
Možná by to šlo i nějakou tabulkou, ne konti a pomocí vzorců, ale to nevím.

Díky.

Příloha: rar27353_kalendare-wall.rar (83kB, staženo 32x)
Zaslat odpověď >

Strana:  1 2   další »
#027359
avatar
Nevím, jestli tomu rozumím, ale zkusím si tipnout. V KT bude Rok a Měsíc v části Popisky sloupců, dále nahoře kontextová karta Nástroje kontingenční tabulky/Návrh, skupina Rozložení, Rozložení sestavy, Zobrazit ve formě osnovy nebo tabulky. Pak uvidíte filtr u obojího.

Pod kartou Možnosti u KT si můžete také Vložit průřez.

Jinak/jindy/jinde funguje na KT volba Data/Seskupit (Excel umí roztřídit i šikovně datumy.citovat
#027365
Alfan
Jenže já právě při použití více listů najednou za Pomoci průvodce KT nevidím ty konkrétní sloupce. Respektive ony se ty sloupce žádají automaticky všechny a já můžu vybrat, které chci vidět, ale nemohu, neumím, dostat ten sloupec rok a měsíc "nahoru" do Filtru KT.
Když dělám standardní KT, tak si pretahuji pole (názvy sloupců v dtaech) tam, kam potřebuji, ale teď mi to nejde.
Mohl byste mi to ukázat na těch datech co jsem dal do prilohy?
Dikycitovat
#027367
avatar
Řeknu, co bych s tím udělal: Sloučil do Tabulky přes SQL dotaz typu UNION ALL a na ní postavil kontingenčku.citovat
icon #027369
eLCHa
@Alfan
Moje odpověď je v podstatě zbytečná, protože jste sám napsal, že to tak nechcete. Ale stejně to považuji za nejlepší řešení a proto to napíšu.
Dejte všechny kalendáře na jeden list a přidejte sloupec s jeho jednoznačným identifikátorem (ABC, KLM). Pokud si budete chtít zobrazit tento kalendář, vyfiltrujete si to pomocí tohoto sloupce. Bude to mít obrovskou výhodu - vytvoříte si to sám a v případě problému si to budete tedy moci sám opravit.
Druhou možnost jste už také zmínil - nepoužít KT, ale vzorce. O to byste se už z principu měl pokusit také sám. Nebo, pokud to nezvládnete, alespoň vytvořte další list, kde bude vzor výstupu. Někdo už to vyplní.

Pokud trváte na svém, pak řešení od xlnc nebo něco podobného.citovat
icon #027378
eLCHa
Použijte kombinaci
=NEPŘÍMÝ.ODKAZ(ODKAZ(řádek;sloupec;[typ];[a1];[list])
Více v nápovědě.

Příklad=SUMA(NEPŘÍMÝ.ODKAZ(ODKAZ(31;10;;;"List1")&":"&ODKAZ(35;10)))citovat
#027379
Alfan
EDIT
Přikládám konkrétní soubor.

Jj, zkusím to pomocí vzorce.
Jen jsem zjistil, že fce SUMIFS neumí udělat oblast za více listů. To mi tolik nevadí.

Ale potřeboval bych poradit se zápisem ve funkci s odkazem na list.
Mám toto:
'1'!$N$1:$N$37
kde ta "1" je název listu, na kterém jsou data.
A ta část '1'!$N$1:$N$37 je součástí vzorce, který zapisuji na list "prehled".
U každé položky na listu "prehled" mám ve sloupci "A" pořadové číslo Předmětu, které odpovídá právě názvu konkrétního listu.

Potřeboval bych se naučit, jak nahradit tu "1" hodnotou z buňky ve sloupci "A" na listu "prehled". Konkrétně ta "1" je v buňce "A3", následuje "2", která je v buňce "A4" atd.
Ale já neumím nahradit '1'! odkazem na ty konkrétní buňky.
Můžete mi někdo prosím poradit?
Děkuji
Příloha: rar27379_kalendare-wall_dnes.rar (85kB, staženo 28x)
citovat
icon #027380
eLCHa
Jsem fakt dobrej. Na Vaší otázku jsem dokázal odpovědět 20 minut před tím, než jste ji položil. ;)))

=IFERROR(SUMIFS(NEPŘÍMÝ.ODKAZ(ODKAZ(1;14;;;$A3)&":"&ODKAZ(200;14));NEPŘÍMÝ.ODKAZ(ODKAZ(1;16;;;$A3)&":"&ODKAZ(200;16));C$2);0)

edit - lubo by se určitě ozval a v tomto případě má pravdu - pro tento případ je lepší=KDYŽ(JE.CHYBHODN(NEPŘÍMÝ.ODKAZ(ODKAZ(1;1;;;$A3)));0;SUMIFS(NEPŘÍMÝ.ODKAZ(ODKAZ(1;14;;;$A3)&":"&ODKAZ(200;14));NEPŘÍMÝ.ODKAZ(ODKAZ(1;16;;;$A3)&":"&ODKAZ(200;16));C$2))protože takto máte ověřeno, jestli existuje list a další chyby se Vám projeví ve výsledku.citovat
#027381
Alfan
@eLCHa Good job, děkuji 1
Já jsem psal, že tu člověku vždy poradí.

Akorát se musím prokousat tím vzorcem, protože je na mě moc složitej, nicméně funguje.

Chci se zeptat, když ta data na listech "1", "2" atd. převedu na tabulky, dá se to?
Bude se muset opravit ten vzorec?
Jde mi o to, že to máte omezené počtem řádků 200, ale jestli by to tas Tabulka neřešila?
Díkycitovat
icon #027382
eLCHa
Vidíte, kdybyste to měl na jednom listu... ;)))

Chci se zeptat, když ta data na listech "1", "2" atd. převedu na tabulky, dá se to?
Bude se muset opravit ten vzorec?
Jde mi o to, že to máte omezené počtem řádků 200, ale jestli by to tas Tabulka neřešila?
Díky


Chvíli jsem nad tím uvažoval, ale o funkci, která by uměla přepnout mezi Tabulkami zatím nevím. Pokud předpokládáte více než 200 splátek, dejte si více řádků a máte postaráno.
Musel byste stejně vzorcem zjistit počet řádků na listu. Nebo alespoň maximální počet splátek ze všech kaledářů - to by šlo zjistit např 3-D vzorcem=MAX('1:2'!B:B)Ale nevím, jestli bych si to takhle komplikoval. Když tam dáte 500 (41 let), tak by Vás to nemělo nijak výrazně zpomalovat a více než 500 splátek stejně nepoužijete. Jestli ano, tak mi dejte kontakt a já si u Vás půjčím ;))

Na tabulky si to stejně převeďte.citovat
#027383
Alfan
JJ, děkuji.
Já to myslel jen s ohledem na rychlost výpočtu.
Těch 200 řádků tutově bude stačit 1citovat

Strana:  1 2   další »

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

cislovanie riadkov

martin1 • 18.1. 20:47

Podmíněné formátování

Baja • 18.1. 18:55

VBA - načtení dat ze souboru s proměnným názvem

Fantasyk • 18.1. 14:29

zápis čísla fce suma

Stalker • 18.1. 13:17

smazání více obrázků

Zdenda-R • 18.1. 9:47

výpis adresáře

Milan-158 • 18.1. 9:31

zápis čísla fce suma

Josef-Sekan • 18.1. 9:26