< návrat zpět

MS Excel


Téma: maticový vzorec rss

Zaslal/a 15.12.2015 17:12

Řeším analytický problém u rozsáhlé tabulky dat, kde potřebuji souhrnně vyčíslit součet poměrných částí z celkových cen (řádek po řádku) v závislosti na poměru jednotek v jednotlivých kategoriích.
Vše, tedy uspořádání dat a zadání, vyplývají z modelové tabulky v listu přiloženého sešitu.
Ve spodní části listu jsou pomocí rozfázovaného výpočtu cílové výsledky z hodnot obsažených v tabulce nahoře. Způsob uvedeného výpočtu je pouze pro názornost, v této podobě je to nepoužitelné. Pomocné výpočty (v originální tabulce by se obtížně včleňovaly) jsou v modře podbarvených buňkách.
Rád bych jednotlivých cílových výsledků (zeleně podbarvené buňky) dosáhl pomocí jediného vzorce, pokud to jde.
Pomůže mi s tím někdo? Předem moc děkuji.

Příloha: zip28704_pokus2.zip (10kB, staženo 24x)
Zaslat odpověď >

#028708
avatar
třeba takto?

Edit 21:50
už se mi to nechce předělávat, ale ...
"JE.ČISLO()" je tam zbytečné, to řeší "CHYBHODN()"
takže něco jako:=SUMA(CHYBHODN($B$3:$B$12/$H$3:$H$12;0)*($C$3:$G$12)*($C$2:$G$2=$B24))"CSE"
Příloha: zip28708_pokus3.zip (11kB, staženo 24x)
citovat
icon #028709
avatar
@kp57
pokiaľ by kolega neplietol do stĺpca B medzi čísla texty, tak by sa ten vzorec dal napísať i takto:=SUM(IFERROR(($C$3:$G$12/$H$3:$H$12);0)*($B$3:$B$12)*($C$2:$G$2=$B16)),ale prečo robiť veci jednoducho, keď to ide zložito. Mne nebolo jasné, prečo mi vzorec nepočíta, až po vzhliadnutí Tvojej verzie som postrehol, že v stĺpci B sú nie vždy čísla. Zdržím sa radšej sprostých poznámok na adresu OP 6citovat
#028710
avatar
Teď se dívám. AL, to je stejný vzorec. Proč by tomu měly vadit ty texty? To přece řeší "CHYBHODN/IFERROR". Mně to fachčí i s nima.citovat
icon #028712
avatar
on nie je rovnaký, ja som stĺpec B vytiahol až za tú IFERROR.. o.k., dá sa i takto:=SUM(IFERROR(($C$3:$G$12/$H$3:$H$12*$B$3:$B$12);0)*($C$2:$G$2=$B16)) a potom tie texty nevadia, i tak si ale myslím, že za miešanie textových hodnôt medzi číselné by si niekto zaslúžil..citovat
#028713
avatar
Pánové, omlouvám se a chápu Vaše rozhořčení. Z mé strany to nebyla léčka a snad ani zhovadilost. V zájmu co nejstručnějšího popisu, jsem opomněl upozornit na to, že kombinace číselných a textových hodnot jsou výsledkem jiných vzorců. V modelové tabulce jsem vepsal varianty hodnot, jak je vrací v originální tabulce vzorce. Zítra Vaše řešení vyzkouším a dám vědět. Zatím díky moc za reakce.citovat
#028761
avatar
Slíbil jsem zpětnou vazbu, tady je. Modifikoval jsem a pro originální aplikaci poněkud rozvedl navržená řešení. Pro zajímavost toto je funkční výsledek mého snažení:
=KDYŽ($A49="";"";ZAOKROUHLIT(SUMA(KDYŽ(JE.CHYBHODN(($U$14:$U$44)/(($V$14:$V$44)+($W$14:$W$44)));0;KDYŽ($BX$14:$BX$44=2;($U$14:$U$44)/(($V$14:$V$44)+($W$14:$W$44)+($V$13:$V$43)+($W$13:$W$43));($U$14:$U$44)/(($V$14:$V$44)+($W$14:$W$44))))*KDYŽ($BX$14:$BX$44=2;(($X$2:$BA$2=$A49)*(($X$14:$BA$44)+($X$13:$BA$43))+($W$2:$AZ$2=$A49)*(($X$14:$BA$44)+($X$13:$BA$43)));(($X$2:$BA$2=$A49)*($X$14:$BA$44)+($W$2:$AZ$2=$A49)*($X$14:$BA$44))));0))
I když bez vysvětlujícího komentáře, detailního zadání a hlavně bez přiložené reálné tabulky je to poněkud celkem málo říkající. Mohu případně doplnit, kdyby byl zájem.
Asi by to šlo ještě upravit a trochu tak zjednodušit a zkrátit, ale já jsem rád, že to funguje, jak má.
Díky ještě jednou, že jste mě nakopli, bez Vás bych to nedal. 9citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Sumar nakupov

Pavlus • 22.1. 13:05

VBA - načtení dat ze souboru s proměnným názvem

Fantasyk • 22.1. 9:12

Sumar nakupov

Robo11 • 21.1. 21:23

VBA - načtení dat ze souboru s proměnným názvem

€Ł мσşqμΐτσ • 21.1. 12:21

Tělo emailu ve VBA - formát

Fantasyk • 20.1. 20:47

odstranenie opakujucich sa udajov v riadkoch

frantilopa • 20.1. 18:12

odstranenie opakujucich sa udajov v riadkoch

marjankaj • 20.1. 18:01