< návrat zpět

MS Excel


Téma: Něco jako POČET a COUNTIFS rss

Zaslal/a 18.8.2016 9:30

Merlin99Zdravím, narazil jsme na problém že mám sloupec dílů a sloupec jejich dodavatelu a potřeboval bych vzorec něco jak POČET nebo COUNTIFS ale aby spocet jen hodnoty jednou.. je to nejak možné díky za napady.. PŘ

Příloha: zip32359_vzorec.zip (7kB, staženo 22x)
Zaslat odpověď >

#032360
avatar
třeba takto, oblast nesmí obsahovat prázné buňky

=SUMA(KDYŽ(ČETNOSTI(POZVYHLEDAT(E14:E22;E14:E22;0);POZVYHLEDAT(E14:E22;E14:E22;0))>0;1))citovat
#032361
Merlin99
veny DÍKY moc top funguje.

Škoda ze jen nejde aby když je pole prázdné tak to nepocitalo nic. Ale super pomohlo 1citovat
#032362
avatar
mám tu ještě na počítání i s prázdnými buňkami, které bere jako jedinečnou hodnotu tak třeba by pomohla kombinace a nebo tě to nasměruje, nemám moc čas teď to zkoušet

A zapomněl jsem dodat že je potřeba vzorec zadat maticově Ctrl+Shift+Enter

v příkladu buňky A1:A17
=SUMA(KDYŽ(ČETNOSTI(KDYŽ(DÉLKA(A1:A17)>0;POZVYHLEDAT(A1:A17;A1:A17;0);"");KDYŽ(DÉLKA(A1:A17)>0;POZVYHLEDAT(A1:A17;A1:A17;0);""))>0;1))

edit:tak mi to nedalo a ještě jsem to vyzkoušel

ten druhej vzorec funguje i když jsou tam prázdné řádky a spočítá oblast tak že je vynechá

ale vyzkoušej ;)citovat
icon #032363
avatar
=SUM(1/COUNTIF(E14:E22; ""&E14:E22))-(COUNTIF(E14:E22;"")>0)maticovocitovat
#032365
avatar
Já to počítám takto (podobně jako AL).
P.

Maticový vzorec:{=SUMA(IFERROR(1/COUNTIF(E14:E22;E14:E22);0))}citovat
#032369
Merlin99
veny
AL
Pavlus
SUPER práce funguje, uložim si vsechny do sbírky DÍKY MOOOOC 9citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

VBA - načtení dat ze souboru s proměnným názvem

€Ł мσşqμΐτσ • 22.1. 19:28

Sumar nakupov

Pavlus • 22.1. 13:05

VBA - načtení dat ze souboru s proměnným názvem

Fantasyk • 22.1. 9:12

Sumar nakupov

Robo11 • 21.1. 21:23

VBA - načtení dat ze souboru s proměnným názvem

€Ł мσşqμΐτσ • 21.1. 12:21

Tělo emailu ve VBA - formát

Fantasyk • 20.1. 20:47

odstranenie opakujucich sa udajov v riadkoch

frantilopa • 20.1. 18:12