< návrat zpět

MS Excel


Téma: Jak snížit počet dat/buněk? (Každá desátá buňka) rss

Zaslal/a 25.8.2016 21:32

Dobrý den,

mám naměřený průběh cca 5000 buněk. Graf se příliš nemění stačilo by mi například 500 - 100 hodnot. Nevím jak udělat filtr který by zobrazoval třeba jen každou cca desátou padesátou buňku.

Zbytek nedef, ve filtru bych vyškrtl všechny tyto políčka a ctr+c ctrl+v dostal zredukovanou tabulku pro práci v jiných programech.

Děkuji za pomoc

s pozdravem Ondra

Zaslat odpověď >

#032439
avatar
Zdravim,

napr. makrem nize:

Sub test()
'kazda 50. bunka
Const iSTEP As Integer = 50

Dim ws As Worksheet
Dim rng As Range, x As Long, LR As Long

'data na listu1
Set ws = Sheets(1)
'oblast dat je A2:Axxx
Set rng = ws.Range("A2:A" & ws.Range("A" & Rows.Count).End(xlUp).Row)
'posledni bunka v oblasti
LR = ws.Range("A" & Rows.Count).End(xlUp).Row

'pozadovana hodnota je kopirovana do nasledujiciho sloupce
For x = 1 To LR Step iSTEP
rng.Item(x).Offset(0, 1) = rng.Item(x)
Next x

'odstraneni prazdnych bunek
rng.Offset(0, 1).SpecialCells(xlCellTypeBlanks).Delete shift:=xlUp
End Sub


sydcitovat
#032444
avatar
Jednoduchá varianta - pomocný sloupec a třeba

=MOD(ŘÁDEK();10)

pak filtrem buď skrýt zbytečné řádky, nebo data zkopírovat jinam.

Pokud lze použít xy graf lze postup zozšířit:
Obvykle jsou zajímavá místa, kde se něco děje.
tj. třeba do dalšího sloupce

=KDYŽ(ABS(A11-PRŮMĚR(POSUN(A10;-9;0;10;1)))>2*SMODCH.P(POSUN(A10;-9;0;10;1));0;10)

- vloží 0 pokud akt. bod se významněji liší od předchozích 10 hodnot

V tomto případě je ale krok nestejný mezi body a je tedy vhodné použití xy grafu.

(doporučuji filtrovat hodnotu 0, pak se dá snadněji měnit počet vybraných položek a není třeba na tyto drobnosti myslet)citovat
#032446
avatar
Děkuji oboum,

bohužel pro mě snadnější cestu s příkazem MOD mi nešlo rozběhnout, když koukám na funkci MOD, tak ani nechápu jak by to mohlo fungovat.

Makra zvládám jen ty nejprimitivnější z nejprimitivnějších, tak je to pro mě horší cesta, ale slepě upravit makro tak abych byl schopen použít mi šlo. Výsledek je elegantní, paráda!

Takže ještě jednou děkuji oboum za darovaný čas.
Příloha: png32446_excel_filtr.png (17kB, staženo 80x)
32446_excel_filtr.png
citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

nezavre samo outlock

€Ł мσşqμΐτσ • 24.7. 9:01

kopirovanie s predosleho mesiaca

€Ł мσşqμΐτσ • 24.7. 8:49

automaticky generator VBA

Michalko • 23.7. 20:32

kopirovanie s predosleho mesiaca

ivana1 • 23.7. 19:25

nezavre samo outlock

peter2 • 23.7. 18:59

upozornění na již existující soubor

Kalous • 23.7. 17:41

Porovnání dat a doplnění.

lachis • 23.7. 12:39