< návrat zpět

MS Excel


Téma: buňka - znak nebo číslice a výpočet dat v excelu rss

Zaslal/a 12.9.2016 9:20

Dobrý den, prosím o radu. Mám buňku, ve které se počítájí celkové odpracované hodiny v závislosti na ostatních buňkách. Nyní bych potřeboval zohlednit ve vzorci další buňku A25, ve které by uživatel vyplnil znaky nebo číslice. Pokud by se v této buňce objevila číslice, tak by se doplnily celkové hodiny (došlo by k násobení), ale pokud by v této buňce byl znak, tak by se neprovedlo nic. Nevíte jak toto v excelu ve vzorci zohlednit?

Celkový vzoreček na počítání hodin je:
=KDYŽ(A(D25="";E25="";G25="";H25="");"";KDYŽ(NEBO(D25="";E25="";G25="";H25="";ZPRAVA(D25;2)>="60";ZPRAVA(E25;2)>="60";ZPRAVA(G25;2)>="60";ZPRAVA(H25;2)>="60");"chyba";KDYŽ((AH25-AG25)+(AJ25-AI25)<=0;"";(AH25-AG25)+(AJ25-AI25))))
a
nyní bych chtěl přidat buňku A25, ve které by se uváděli čísla anebo číslice.

Děkuji moc.
Honza

Zaslat odpověď >

#032759
avatar
použít další fci =KDYŽ(JE.ČÍSLO(A25);vámi požadovaný výpočet;vámi požadovaný výstup při jiné hodnotě než je číslo)citovat
#032761
MePExG
=KDYŽ(A(D25="";E25="";G25="";H25="");"";KDYŽ(NEBO(D25="";E25="";G25="";H25="";ZPRAVA(D25;2)>="60";ZPRAVA(E25;2)>="60";ZPRAVA(G25;2)>="60";ZPRAVA(H25;2)>="60");"chyba";KDYŽ((AH25-AG25)+(AJ25-AI25)<=0;"";(AH25-AG25)+(AJ25-AI25))))*
když(je.číslo(a25);a25;1)citovat
#032762
avatar

mepexg napsal/a:

=KDYŽ(A(D25="";E25="";G25="";H25="");"";KDYŽ(NEBO(D25="";E25="";G25="";H25="";ZPRAVA(D25;2)>="60";ZPRAVA(E25;2)>="60";ZPRAVA(G25;2)>="60";ZPRAVA(H25;2)>="60");"chyba";KDYŽ((AH25-AG25)+(AJ25-AI25)<=0;"";(AH25-AG25)+(AJ25-AI25))))*
když(je.číslo(a25);a25;1)

Násobenie jednotkou znamená, že "se neprovedlo nic"???
Niektorí zadávatelia by si mali svoju otázku aj po sebe prečítať. 4citovat
#032833
avatar
Díky, ale jak ošetřit výpočet pokud se jedná o čas? Protože mi výpočet následně končí chybou: #HODNOTA!
Díkycitovat
#032834
avatar
Přilož ukázku dat...
P.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

cislovanie riadkov

martin1 • 18.1. 20:47

Podmíněné formátování

Baja • 18.1. 18:55

VBA - načtení dat ze souboru s proměnným názvem

Fantasyk • 18.1. 14:29

zápis čísla fce suma

Stalker • 18.1. 13:17

smazání více obrázků

Zdenda-R • 18.1. 9:47

výpis adresáře

Milan-158 • 18.1. 9:31

zápis čísla fce suma

Josef-Sekan • 18.1. 9:26