< návrat zpět

MS Excel


Téma: Konkrétní číslice na konkrétní pozici rss

Zaslal/a 3.1.2017 16:53

Ahojte
měl bych prosím jednu banalitní otázečku pro zdejší guru.
Potřebuji do fce Když jako podmínku zjistit zda určitá buňka obshuje na konkrétní pozici konkrétní číslici.V prohledávané buňce je vzorec

asi nemá cenu vkládat přílohu

=KDYŽ(A1="*1";Ano;Ne) poslední číslice pro buňku A1 je 1 v případě shody Ano jinak Ne

samozřejmě že mi toto nefunguje 5

děkuji V.

Zaslat odpověď >

#034162
avatar
Od boku:

=KDYŽ(ZPRAVA(A1;1)="1";"ano";"ne")

nebo

=KDYŽ(HODNOTA(ZPRAVA(A1;1))=1;"ano";"ne")citovat
#034163
avatar
Pokud by se jednalo o textový kód, prostě ve výsledku o text, pak jde i něco, co jste zkoušel:

=KDYŽ(COUNTIF(A1;"*1")=1;"ano";"ne")citovat
#034168
avatar
Díky moc použil jsem hned první a po malé úpravě pro mé potřeby se dobral ke zdárnému konci 1

edit:
mohl bych se ještě zeptat už jen ze zvědavosti jak by se dalo řešit nalezení konkrétní číslice v konkrétním umístění čísla?

např.: v sedmimístném čísle na třetí pozici zprava zda je číslice xcitovat
#034169
avatar
=LEFT(RIGHT(A1;3);1)

=MID(A1;LEN(A1)-3+1;1)citovat
#034172
avatar
Je takový problém zjistit, že kromě ZPRAVA, je i ZLEVA a ČÁST? Karta Vzorce / Knihovna funkcí / Text...citovat
#034173
avatar

xlnc napsal/a:

Je takový problém zjistit, že kromě ZPRAVA, je i ZLEVA a ČÁST? Karta Vzorce / Knihovna funkcí / Text...

problém to samozřejmě není, vím že ty funkce existují a popravdě jim moc nerozumím, proto jsem se zeptal.

vzorec od "marjankaj" =ZLEVA(ZPRAVA(A1;3);1) třeba nechápu, jediné co jsem z toho pravděpodobně vydedukoval je to, že je tím ZLEVA ošetřeno aby vzorec vrátil hodnotu právě té jedné konkrétní číslice

edit: a když to tak zkoumám tak jsem na to přišel, fce ZPRAVA najde tři poslední znaky a z toho fce ZLEVA můj požadovaný

jak jednoduché 4 stačí přemýšletcitovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

VBA - načtení dat ze souboru s proměnným názvem

€Ł мσşqμΐτσ • 22.1. 19:28

Sumar nakupov

Pavlus • 22.1. 13:05

VBA - načtení dat ze souboru s proměnným názvem

Fantasyk • 22.1. 9:12

Sumar nakupov

Robo11 • 21.1. 21:23

VBA - načtení dat ze souboru s proměnným názvem

€Ł мσşqμΐτσ • 21.1. 12:21

Tělo emailu ve VBA - formát

Fantasyk • 20.1. 20:47

odstranenie opakujucich sa udajov v riadkoch

frantilopa • 20.1. 18:12