< návrat zpět

MS Excel


Téma: Výpis hodnot rss

Zaslal/a 2.3.2017 12:03

Přeji hezký den.
Potřeboval bych poradit se vzorcem pro výpis hodnot ze sloupce. Něco jako jedinečné hodnoty, ale s tím rozdílem, že v souvislé řadě jsou vnořené jiné hodnoty. Viz. ukázka.
Předem děkuji.

Příloha: xlsx35226_vypis-hodnot-s-casem.xlsx (11kB, staženo 63x)
Zaslat odpověď >

#035228
elninoslov
Ešte raz. Čože to má určiť, čo je jedinečná hodnota a čo nie ???citovat
#035229
avatar
Jak to napsat. V sloupci je řada čísel např. 1,1,1,1,2,2,2,3,3,3,4,1,1,1,1,2,2,2 v jiném sloupci by byl výsledek 1,2,3,4,1,2 a k těmto hodnotám přiřazen čas, který odpovídá první hodnotě v řadě. Dle vzoru v sloupcich "K" a "L". Sloupce "G" a "H" nebrat do úvahy. Snad jsem to popsal správně.citovat
#035230
avatar
Jde ti tedy vlastně o vyfiltrování hodnot, které mají ve sloupci "vp" jinou hodnotu na řádku "x" vůči řádku "x-1". Takže stačí přidat pomocný sloupec s touto podmínkou, například něco takovéhoto:
=KDYŽ(D1<>D2;1;0)Výsledek pak můžeš získat klasickým filtrováním zdrojové tabulky (filtrovat jedničky), případně si můžeš udělat kontingenční tabulku.
P.

Viz příloha:
Příloha: xlsx35230_vypis-hodnot-s-casem-reseni.xlsx (16kB, staženo 47x)
citovat
#035231
avatar

Pavlus napsal/a:

Jde ti tedy vlastně o vyfiltrování hodnot,

Ano máš pravdu, jde o filtrování hodnot. S tím pomocným sloupcem to mám tak udělané, jenže z těch 20 sloupců potřebuji vyhodnotit 10 sloupců(10 pomocných) x 2880 řádků x 10 zařízení(a budou přibývat) to nabývá dost na velikosti souboru.
Ja jsem použil do druhého řádku pomocného sloupce vorec=KDYŽ(D2=D3;E2;E2+1) a pak se odkazuji na patřičné buňky. Právě těch pomocných sloupců bych se rád tímto způsobem zbavil.citovat
#035238
Stalker
Něco sem zkusil za pomoci polí. Možná to k něčemu bude.
Příloha: zip35238_vypis-hodnot-s-casem.zip (15kB, staženo 45x)
citovat
#035240
elninoslov
Toľko buniek by som radšej po jednej nekontroloval (to sú desiatky tisíc). Navrhujem najskôr celú oblasť dať do poľa.
Príklad urobený tak, že sa pri každej aktivácii listu, ktorý nieje vo výnimkách (viď makro), aktualizuje zoznam skupín na danom liste.
Příloha: zip35240_skupiny-cisel-a-casov.zip (21kB, staženo 39x)
citovat
#035248
avatar
Hezký den.
Děkuji "Stalker" a "elninoslov" za jejich nápady. Přes víkend se budu snažit vaše makra doladit na moje data. Snad se mi to podaří. Myslel jsem si bláhově, že to půjde přes vzorec, ale jak je vidět makro bude lepší. Ještě jednou děkuji. 1citovat
#035263
avatar
Zdravím,
tak jsem to tak nějak dal dohromady. Jestli se to dá udělat jinak a lépe budu rád za každý návrh. 10
Příloha: zip35263_skupiny-cisel-a-casu.zip (362kB, staženo 46x)
citovat
#035265
elninoslov
A nepotrebujete si tie tabuľky skupín pred zápisom nových, najskôr vymazať? Ak áno môžete to urobiť teda pred každým zápisom poľa Skupiny, alebo jednorázovo na začiatku makra napr.
List4.Range("C2:D20,K2:L20,S2:T20,C22:D40,K22:L40,S22:T40,C42:D60,K42:L60,S42:T60").ClearCOntents
alebo napr výmenou stredu makra za:
ReDim Skupiny(1 To 19, 1 To 2)
Skupiny(1, 1) = Cas(1, 1): Skupiny(1, 2) = Co(1, 1)

For i = 2 To Riadkov
If Co(i, 1) <> Co(i - 1, 1) Then
u = u + 1
Skupiny(u, 1) = Cas(i, 1): Skupiny(u, 2) = Co(i, 1)
End If
Next i

With List4.Cells(2 + Dolu, 3 + VpravoStroj2)
.Resize(19, 2) = Skupiny
.Resize(19).NumberFormat = "h:mm:ss"
End With

kde sa nepoužije dynamické pole, ale statické, čo má za následok zmazanie nevyplnených hodnôt.citovat
#035266
avatar

elninoslov napsal/a:

A nepotrebujete si tie tabuľky skupín pred zápisom nových, najskôr vymazať?

Děkuji za připomínku, ale tento soubor slouží jako vzor, do kterého se dodají data za 24 h a pak se uloží pod patřičným datem a pak se vyhodnotí. Výsledky se přetáhnou do měsíčního souboru. Tím pádem se nemusí buňky, které jsou naplněny makrem přepisovat.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Zaokrouhlování

JoKe • 14.6. 15:19

Zaokrouhlování

Mirek-Kraus • 14.6. 13:52

excell uprava riadku vzorca

veny • 14.6. 7:52

excell uprava riadku vzorca

orangezradca • 13.6. 20:37

pomala tlac s exelu

jano5 • 12.6. 9:44

GRAF teploty

JoKe • 12.6. 9:22

Filtrování dat

Imh0tep • 12.6. 8:35