< návrat zpět

MS Excel


Téma: sčítání výsledků rss

Zaslal/a 7.3.2017 13:29

Potřebuji pomoci se sčítáním. Zapisuji si do excelovské tabulky pod sebou výsledky ve formátu číslo-číslo (např. 1-0, 1-2, atd.) a chtěl bych, aby mi excel pod sloupečkem takových výsledků spočítal celek. Tedy aby když tam pod sebou budou vstupy např. 1-0, 0-1 a 1-1, tak aby mi z toho dole spočítal 2-2. Je toto vůbec nějak možné, případně s použitím jiného znaménka, než pomlčky?
Děkuji

Zaslat odpověď >

Strana:  « předchozí  1 2
#035342
avatar
Bohužel i tak to hází chybný výsledek "#NÁZEV?"citovat
#035343
Stalker
Koukni do souboru.
Příloha: xlsx35343_wall-secti.xlsx (9kB, staženo 30x)
citovat
#035347
avatar
Díky, už to funguje :)citovat
#035348
avatar

djirka napsal/a:

Díky, už to funguje :)


Ale iba s jednocifernými hodnotami. Pri číslach nad 9 treba zložitejší vzorec.citovat
#035350
elninoslov
marjankaj má na mysli niečo takéto (maticovo):
=SUM(LEFT(C1:C4;FIND("-";C1:C4)-1)*1)&"-"&SUM(RIGHT(C1:C4;LEN(C1:C4)-FIND("-";C1:C4))*1)
=SUMA(ZLEVA(C1:C4;NAJÍT("-";C1:C4)-1)*1)&"-"&SUMA(ZPRAVA(C1:C4;DÉLKA(C1:C4)-NAJÍT("-";C1:C4))*1)

alebo
=SUM(LEFT(C1:C4;FIND("-";C1:C4)-1)*1)&"-"&SUM(REPLACE(C1:C4;1;FIND("-";C1:C4);"")*1)
=SUMA(ZLEVA(C1:C4;NAJÍT("-";C1:C4)-1)*1)&"-"&SUMA(NAHRADIT(C1:C4;1;NAJÍT("-";C1:C4);"")*1)
citovat
#035362
avatar
@elninoslov
Že sa ti to vôbec chcelo takto vypisovať.
Najjednoduchšie je rozdeliť to na dva stlpce. tie spočítať a prípadne znovu spojiť do jedného.
Žasnem niekedy aké "prkotiny" tu niektorí potrebujú vyriešiť.

Navyše som to skúšal zadať do bunky 1-1 a vyhodilo mi to dátum. Skrátka niečo úžasné.citovat

Strana:  « předchozí  1 2

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Která Ip otevřela sešit

Barth • 23.9. 12:27

Která Ip otevřela sešit

Barth • 23.9. 10:15

Která Ip otevřela sešit

Barth • 23.9. 9:48

Která Ip otevřela sešit

Scraper • 22.9. 12:47

Vyhledat s vícenásobných porovnáním

maxovo • 22.9. 11:29

spustit makro změnou hodnoty v buňce a svyhledat

Stalker • 21.9. 20:36

spustit makro změnou hodnoty v buňce a svyhledat

elninoslov • 21.9. 19:01