< návrat zpět

MS Excel


Téma: Porovnavanie dvoch texto, hladanie rss

Zaslal/a 2.8.2017 11:18

Dobry den
Chcel by som sa opytat ci existuje nejaka moznost v excel porovnat dva subory kde su v bunach rozpisane len 8miestne kody produktov s tym aby mi nasledne vypisalo ze v tom druhom dokumente chybaju tieto kody. Ide o to ze v eshope mam synchronizaciu kodov s dodavatelskym skladom a dodavatel uz niektore produkty (kody) v exportnom subore nema a ja ich na stranke mam a chcem ich odstranit. Aby som to nemusel rucne hladat kedze je ich cca 10 000.

Dakujem

Zaslat odpověď >

Strana:  « předchozí  1 2
#037057
avatar
marjankaj - Dakujem velmi pekne :) takto som si predstavoval pomoc super vazim si to :)
Ale nefunguje to stale mi tam pise v tom stlpci B chybu ze #NÁZEV?
Nevies kde by mohol byt problem?
A potom ako si pisal odstranit riadky mam teda ktore? vsetky?
Ak tak kludne mi posli mail napisem ti sukromne a budem sa revanzovat pre mna je to fakt velmi velka pomoc ked si tymto pomozem.
Dikcitovat
#037058
elninoslov
Používate asi CZ Excel, tak zmente vzorec na český:
=KDYŽ(COUNTIF(A1;C:C)=0;NEDEF();"ok")
Odstránenie:
Po tom čo urobíte, ako bolo napísané, ostanú označené chybné bunky. Pravý klik, Odstrániť, Celý riadok.citovat
#037060
avatar
Ano pouzivam cesky excel, uz to funguje ale funguje to tak ze OK mi napise iba v pripade ze ten kod je rovnaky v jednom riadku, akonahle je kod rovnaky aj v stlpci A aj v stlpci C ale nie je uz na rovnakom riadku ale napriklad v stlpci A je v riadku 5 a v stlpci C je ten isty kod v riadku 20 tak uz mi to vypise ako chybu a prave o to mi ide pretoze neviem tie produkty zoradit podla niecoho.. Este ma napadlo ze ak takato funkcia neexistuje aby to vyhladavalo ci by sa najskor nedalo tie kody zoradit podla cisla dajme tomu v oboch stlpcoch a potom ich dat takto prekontrolovat?citovat
#037061
avatar
No zabudol som povedať, že keď to všetko urobíš, tak ten stlpec B môžeš vymazať.
Filtrovať alebo zoraďovať tie zoznamy môžeš hocikedy.citovat
#037065
avatar

Matus napsal/a:

ale funguje to tak ze OK mi napise iba v pripade ze ten kod je rovnaky v jednom riadku, akonahle je kod rovnaky aj v stlpci A aj v stlpci C ale nie je uz na rovnakom riadku ale napriklad v stlpci A je v riadku 5 a v stlpci C je ten isty kod v riadku 20 tak uz mi to vypise ako chybu

nevím jak je to u ENG excelu ale pro český je potřeba zadat ve fci COUNTIF nejprve oblast hledání a potom kriterium takže vzorec by měl být

=KDYŽ(COUNTIF(C:C;A1)=0;NEDEF();"ok")citovat
#037069
avatar

veny napsal/a:

Matus napsal/a:ale funguje to tak ze OK mi napise iba v pripade ze ten kod je rovnaky v jednom riadku, akonahle je kod rovnaky aj v stlpci A aj v stlpci C ale nie je uz na rovnakom riadku ale napriklad v stlpci A je v riadku 5 a v stlpci C je ten isty kod v riadku 20 tak uz mi to vypise ako chybu
nevím jak je to u ENG excelu ale pro český je potřeba zadat ve fci COUNTIF nejprve oblast hledání a potom kriterium takže vzorec by měl být

=KDYŽ(COUNTIF(C:C;A1)=0;NEDEF();"ok")


Supeer 9 uz to funguje :)

Dakujem Vam vsetkym velmi pekne elninoslov, marjankaj.. Velmi ste mi pomohli keby som sa mal ako odvdacit, usetrili ste mi strasne vela casu :) 1 1 1 1citovat
#037070
avatar
@veny
Máš pravdu aj v anglickom exceli je to rovnako.
No vloudila se chybička. 6citovat

Strana:  « předchozí  1 2

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

export xls - konkrétní sloupce a pořadí

Alfan • 30.9. 15:11

open book

elninoslov • 30.9. 13:36

Podmíněné formátování - kopírování

elninoslov • 30.9. 13:30

export xls - konkrétní sloupce a pořadí

elninoslov • 30.9. 13:17

spustit makro změnou hodnoty v buňce a svyhledat

PavDD • 30.9. 10:10

Podmíněné formátování - kopírování

mikar • 30.9. 9:58

open book

PavDD • 30.9. 9:23