< návrat zpět

MS Excel


Téma: excel - nedokážu napsat vzorec rss

Zaslal/a 26.9.2017 19:13

mám vzorec -A1-DNES() , v sloupci A mám datum termínu splnění úkolu a vypočítávám dny zbývající do termínu.Potřebuji, aby při A1-DNES()<-10 se do sloupce A nevypočítávaly další hodnoty, ale byla tam nula. Je to možné dokázat nějakou (složenou)? Prosím o pomoc.

díky jerry 7

Zaslat odpověď >

#037750
avatar
=KDYŽ(A1-DNES()<-10;0;A1-DNES())citovat
#037752
avatar
Děkuji za expresní odpověď!
Promiˇnte, ale posílám ještě rozšířený dotaz: bylo by možné (viz přiložený soubor) zachovávat v K4 dosaženou číselnou hodnotu (např -23) ve chvíli odevzdání - bunka L4 není prázdná. A tuto hodnotu zachovávat napořád?
4 .

ještě jednou srdečně děkuji
jerry
Příloha: xlsx37752_novy-dotaz.xlsx (101kB, staženo 27x)
citovat
#037753
elninoslov
Čo je to zase za dotaz ?
Máte tam niekoľko rôznych vyhodnotení v tom K. Upresnite aj prioritu a výsledok.
Príklad:
-Ak nieje žiaden dátum v J, tak nič nerob.
-Ak je dátum v J a zároveň je dátum v L, tak napíš "ukonč."
-Ak je rozdiel J-Dnes kladný (teda termín nevypršal), napíš rozdiel
-Ak je rozdiel J-Dnes záporný (teda termín vypršal), a menší ako -10, napíš 0
-Alebo inak napíš rozdiel J-Dnes

Teda pr.
=IF(J3="";"";IF(L3<>"";"ukonč.";IF(J3-TODAY()>0;J3-TODAY();IF(J3-TODAY()<-10;0;J3-TODAY()))))
=KDYŽ(J3="";"";KDYŽ(L3<>"";"ukonč.";KDYŽ(J3-DNES()>0;J3-DNES();KDYŽ(J3-DNES()<-10;0;J3-DNES()))))
citovat
#037755
avatar
Dobrý den.
Mrzí mě, že jsem svůj problém popsal tak chaoticky. Potrebuji:
Jakmile není ve sl.L nic, počítej
Jakmile je ve sl.L cokoliv, zastav počítání a zobrazuj stále poslední hodnotu.

Děkuji jerrycitovat
#037757
elninoslov
Čo v tomto prípade znamená
...zastav počítání...
a
...zobrazuj stále poslední hodnotu...
fakt neviem. Iteračný výpočet ? Na tento výpočet nieje nič naviazané, ani on sám nieje na nič naviazaný, teda neexistuje žiadna posledná hodnota. Vy asi chcete :
-pokiaľ nieje ukončenie, počítaj rozdiel medzi DNES a termínom.
-pokiaľ existuje ukončenie, počítaj rozdiel medzi ukončením a termínom.
Je to tak ? Ak áno tak. napr.:
=IF(J3="";"";IF(L3<>"";J3-L3;J3-TODAY()))
=KDYŽ(J3="";"";KDYŽ(L3<>"";J3-L3;J3-DNES()))

bez ošetrenia, či vôbec je niečo v J je to bez prvého IF/KDYŽ:
=IF(L3<>"";J3-L3;J3-TODAY())
=KDYŽ(L3<>"";J3-L3;J3-DNES())
citovat
#037759
avatar
Dobrý den,

je to se mnou ale práce, že?
Vaše analýza je perfektní - už to funguje.

děkuji moc, jste borec!!!!

jerrycitovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse