< návrat zpět

MS Excel


Téma: Jak oddělit číslo ulice do dalšího sloupce rss

Zaslal/a 10.10.2017 15:05

Ahoj,řeším problém, kdy mám název ulice včetně čísel v jednom sloupci. Chtěl bych aby číslo ulice bylo v následujícím sloupci.

Adresy jsou ruzného typu např:

Krajířské náměstí 1762
Stará Spojovací 2263/9
Karla Čapka 296
U Hřiště
Vaníčkova 2b
Vídeňská 297/99
Kovanecká 2405/27
Mukařovského 2590/2
Revoluční 82
Slovany 3051
Cukrovarská 30
T.G. Masaryka 897
V Lukách 1362
Polská 1360
tř. T. G. Masaryka 454
8. května 6/2

Existuje nějaký způsob ?
Děkuji

Zaslat odpověď >

icon #037879
eLCHa
V rychlosti jsem sesmolil takovýto vzorec=ČÁST(A1;NAJÍT("#";DOSADIT(A1;" ";"#";DÉLKA(A1)-DÉLKA(DOSADIT(A1;" ";""))))+1;1000)Nefunguje u "U Hřiště", protože tam není číslo.
Prostě hledám poslední mezeru a co je za ní, to vypíšu. Ale nikdy to nebude 100%citovat
#037880
avatar
super díky, i kdyby to bylo jen 50%, tak porad mi to dost ustri praci. Tech adres je 1500 ;)citovat
#037881
avatar
Jak ted tedy jeste odstranim to cislo abych mel ciste jen adresu ?citovat
#037882
elninoslov
Tak to očúrajte poupravením vzorca od eLCHa a je to tak na 99,4569832000001 %.
Definovaný názov KONIEC:
=MID($A1;FIND("#";SUBSTITUTE($A1;" ";"#";LEN($A1)-LEN(SUBSTITUTE($A1;" ";""))))+1;1000)
=ČÁST($A1;NAJÍT("#";DOSADIT($A1;" ";"#";DÉLKA($A1)-DÉLKA(DOSADIT($A1;" ";""))))+1;1000)


Ulica:
=IF(OR(ISNUMBER(--LEFT(KONIEC;1));ISNUMBER(--RIGHT(KONIEC;1)));KONIEC;"")
=KDYŽ(NEBO(JE.ČISLO(--ZLEVA(KONIEC;1));JE.ČISLO(--ZPRAVA(KONIEC;1)));KONIEC;"")


Číslo (ak nieje, tak ""):
=IF(OR(ISNUMBER(--LEFT(KONIEC;1));ISNUMBER(--RIGHT(KONIEC;1)));LEFT(A1;FIND("#";SUBSTITUTE(A1;" ";"#";LEN(A1)-LEN(SUBSTITUTE(A1;" ";"")))));A1)
=KDYŽ(NEBO(JE.ČISLO(--ZLEVA(KONIEC;1));JE.ČISLO(--ZPRAVA(KONIEC;1)));ZLEVA(A1;NAJÍT("#";DOSADIT(A1;" ";"#";DÉLKA(A1)-DÉLKA(DOSADIT(A1;" ";"")))));A1)

Za číslo na konci sa považuje prípad, aj je prvý alebo posledný znak číselný. Teda aj "2b", "b2", "6/2" a pod.
Příloha: xlsx37882_rozdelenie-adries.xlsx (10kB, staženo 109x)
citovat
#037887
avatar
A nejlépe regulární výrazy... v příkladu zaměněna poslední mezera za tabulátor, což může posloužit jako oddělovač pro Excel Data / Text do sloupců.
Příloha: png37887_regex.png (15kB, staženo 159x)
37887_regex.png
citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse