< návrat zpět

MS Excel


Téma: Funkce hledat + hledat z více slov rss

Zaslal/a 21.12.2017 15:15

Zdravím takto před vánoci,
mohu poprosit o pomoc s vzorcem.
Snažím se nějak zkombinovat vzorec:
=ZVOLIT((IFERROR(HLEDAT(E2;A2);0)>0)+1;"Nenalezeno";"Hledané slovo nalezeno")

ve zkratce ve sloupci A mám text který může obsahovat hledané slovo které budu mít v sloupci E. Vzorce funguje, ale nastane problém když ve sloupci E nebudu mít nic (nechci zrovna nic hledat) pak teda když je buňka prázdná tak mi to vyhlásí všude jako že text nalezen :( ano dalo by se vyřešit do buňky E napsat nějaký nesmysl, ale protože mi jde hlavně pak jde o variantu 2 viz příloha kde bych chtěl docílit toho že ve sloupci E například E1 až E10 bude pod sebou napsáno 1 ale i až třeba 7 nebo 10 slov které chci vyhledat tak mi zmíněný problém nastává že bych nějaký nesmyslný text musel napsat do prázdných řádků dopsat.

Pro jistotu Exel 2013 CZ

Příloha: xlsx38846_hledani.xlsx (11kB, staženo 37x)
Zaslat odpověď >

#038847
avatar
=KDYŽ(DÉLKA(E2)>0;ZVOLIT((IFERROR(HLEDAT(E2;A2);0)>0)+1;"Nenalezeno";"Hledané slovo nalezeno");" nehledej")citovat
#039887
avatar
Omlouvám se že se k tomu vracím až teď.
Zmíněná funkce je OK, ale jen pokut budu hledat jen jedno slovo které bude napsáno v buňce E2. Já bych ale rád docílil toho že mohu hledat ne jen jedno slovo, ale i vice které se může v bunce A2 oběvit, tak že bych do sloupce E pod sebe zadával hledané slova(Např nastavit na rozsach E2 až E10).
Doufal jsme že bude fungovat teda
=KDYŽ(DÉLKA(E2:E10)>0;ZVOLIT((IFERROR(HLEDAT(E2:E10;A2);0)>0)+1;"Nenalezeno";"Hledané slovo nalezeno");" nehledej")

ale to mě stále funguje s tím že porovnává jen slovo z buňky E2.
Menší problém je že pak netuším jak rozkopírovat na více řádků jinak než ho ručně přepisovat. Roztažení o řádek níže se mi změní správně buňka kde chci hledat z A2 na A3 to je OK, ale zároveň co hledat z E2 na E3 (toto bych potřeboval aby se neměnilo, netušíte jak toto obejít abch mohl rozkopírovat na cca 500 řádků?)citovat
#039888
elninoslov
Maticový vzorec (Ctrl+Shift+Enter):
=IF(A2="";"";CHOOSE((MAX(IFERROR(SEARCH(IF($E$2:$E$12="";"žčťžčťžčťžčť";$E$2:$E$12);A2);0))>0)+1;"Nenalezeno";"Hledané slovo nalezeno"))
=KDYŽ(A2="";"";ZVOLIT((MAX(IFERROR(HLEDAT(KDYŽ($E$2:$E$12="";"žčťžčťžčťžčť";$E$2:$E$12);A2);0))>0)+1;"Nenalezeno";"Hledané slovo nalezeno"))

Oblasť slov je v $E$2:$E$12, stačí zmeniť. Vzorec je normálne naťahovací.citovat
#039910
avatar
Super, děkuji moc. Toto je přesně co jsem hledal.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse