< návrat zpět

MS Excel


Téma: Exel VBA Hledání v exter. sešitě a vrácení přile rss

Zaslal/a 22.1.2018 9:57

Zdravím Kouzelníci
Vekou část celého minulého týdne jsem řešil jak vytvořit makro které by ulehčilo práci. Kopíroval jsem různě nalezené kody z internetu do makra ale bez uspěchu. Ze zoufalství se na vás obracím s prozbou o pomoc. Jsem běžný uživatel jehož vývoj skončil u podmíněného formátování a vyhledání v tabulce hodnot. K makrům jsem zatím ani nečichnul velmi mi to stěžuje neznalost AJ.

Mám pracovní sešit se senamem unikátních klíčů položek v buŇkách B5:B255. Potřeboval bych tyto klíče vyhledat v externím sešitě v buňkách A2:A2500 a do toho pracovního sešitu nakopírovat 6 buňek v pravo od nalezeného klíče v externím sešitě.
Viz PrtScrn v příloze.
Můžete mi s tím prosím pomoci?
Předem děkuji

Příloha: jpg39169_dotaz.jpg (347kB, staženo 41x)
39169_dotaz.jpg
Jméno
Kontrola
Text
  b i u s img code url hr   1 2 3 4 5 6 7 8 9 10

#039173
elninoslov
No a normálny VLOOKUP/SVYHLEDAT Vám nefachá?

PS: Nezabudnite, že musíte mať vzorce v stĺpcoch C:H nakopírované na správny počet riadkov pre každú zákazku, keď už to chcete mať takto rozdelené.
Příloha: zip39173_hladanie-v-inom-zosite.zip (18kB, staženo 26x)
citovat
#039175
avatar
No nefachá zkoušel jsem
C5:=SVYHLEDAT($B5;[Dim_EXP.xls]DIMENZE_export!$A$3:$B$2500;2)
D5:=SVYHLEDAT($B5;[Dim_EXP.xls]DIMENZE_export!$A$3:$C$2500;3)
E5:=SVYHLEDAT($B5;[Dim_EXP.xls]DIMENZE_export!$A$3:$D$2500;4)
A tak dále.
A pak překopírovat do ostatních buněk.
A už vím proč.
Protože externí soubor je automatický export z účetního systemu vše je formátováno jako text a před tím duležitým klíčem pole kterého se hledá je apostrof jako takto '7139.
Funkce SVYHLEDAT je uspěšná jen v případě že data jsou seřazena vzestupně podle prvního sloupce.
V případě exportu je to velmi nerealné k tomu ten apostrof. Export nelze ovlivnit.
Myslím že se bez makra ktré bude hledat řetězec znaků to asi nepude.
Jak sem psal už sem se stím hodně natrápil.
ALe i tak děkuji za reakci.citovat
#039176
elninoslov
No tak ten apostrof hromadne odstráňte.

Inak zabudli sme obaja v rýchlosti zadať posledný parameter FALSE/NEPRAVDA, ktorý rieši nezoradené položky. Prílohu som vymenil.

Keď prídem, ešte na to pozriem, ale bodla by reálna príloha (nechajte formáty, rozmiestnenie, zredukujte len počet a citlivé dáta).citovat
icon #039177
eLCHa
Použijte poslední argument NEPRAVDA a první argument převeďte na text. Mělo by to fungovat=SVYHLEDAT(""&$B5;[Dim_EXP.xls]DIMENZE_export!$A$3:$B$2500;2;NEPRAVDA)citovat
#039178
avatar
Posílám pro test ten ext soubor. Trohu sem to promáz na 300 položek.
Jinak ještě zkusím co psal El.cha
Rád bych kdyby to fungovalo bej zásahu do toho ext souboru.
Příloha: zip39178_dim_exp.zip (23kB, staženo 21x)
citovat
#039179
elninoslov
Tak, tak, treba "" a nie "'" aby to frčalo.

EDIT: A keď budeme uvažovať atribúty za textové položky, čo podľa všetkého vždy sú, tak v týchto 3 stĺpcoch obalte VLOOKUP/SVYHLEDAT do REPT/OPAKOVAT aby Vám neukazovalo 0 ak je prázdne pole.
Příloha: xlsx39179_zakazky.xlsx (28kB, staženo 24x)
citovat
#039182
avatar
Pánové Mágové,
Děkuji vypadá to zatím dobře. Vyzkouším v realu.
Ta NEPRAVDA byl velký zlom a pokrok v postupu.

Ještě k tomu klíči skusím přičíst ten apostrof abych to nemusel zadávat z apostrofem.

Díky
Stanislavcitovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse