< návrat zpět

MS Excel


Téma: Převod jednotek času rss

Zaslal/a 12.2.2018 11:38

JAKDobrý den, vím, že se to tu už několikrát řešilo, ale nedokážu najít odpověď na tento konkrétní problém. Potřebuji převést minut na hodiny, minuty a vteřiny: mám číslo 125 a potřebuji aby se mi převedlo do formátu 02:05:00 (hh:mm:ss). Dále mám číslo 125:10 a potřebuji aby se mi převedlo do formátu 02:05:10 (hh:mm:ss). Moc děkuji za radu.

Zaslat odpověď >

#039488
avatar
125:10 nie je číslo. Teda je ale hiodnota toho čísla je úplne iná.citovat
#039491
JAK
Pardon, v tuto chvíli to mám nastavené ve formátu [h]:mm. Díkycitovat
#039492
avatar
A to číslo 125 máš zapísané ako 125:00 alebo ako?
Pozri funkciu TIME/ČAScitovat
#039494
JAK
Mám ho zapsané jako číslo, ale můžu to jakkoliv upravit.citovat
#039497
avatar
125 znamená 125 dní
125:00 znamená 125 hodín
0:125:00 znamená 125 minút

Ako mám bez prílohy vedieť ako to máš zapísané? Nemiešaj tu hrušky s jablkami. 4citovat
#039499
JAK
Mám řadu čísel, které jsou ve formátu číslo 125, 59, 478, ... a potřeboval bych to převést do formátu hodin (hh:mm:ss) tedy 2:05:00, 0:59:00, 7:58:00. V druhém případě mám ve formátu [h]:mm řadu čísel 125:10, 59:30,... A potřeboval bych se dostat ke tvaru 2:05:10, 0:59:30. Je to nějak řešitelné? Díky.citovat
#039501
avatar
A príloha nikde?
=125/60/24
=59/60/24
=478/60/24
A naformátuj si to ako potrebuješ.
Ale ak v tom čísle budeš mať dvojbodky, tak to bude inak.
V tomto prípade
=TIME(0;125;10) teda ČAS(0;125;10) atďcitovat
#039502
elninoslov
Ak to bude text "125:10" tak môžete použiť:
=TIMEVALUE("0:"&A1)
=ČASHODN("0:"&A1)
citovat
#039503
avatar

elninoslov napsal/a:

Ak to bude text "125:10" tak môžete použiť:
=TIMEVALUE("0:"&A1)
=ČASHODN("0:"&A1)

To text nebude, má tam formát [h]:mm .
Bez prílohy to je ako s hotentotom. Buď nevie čítať alebo má vypnurý riadok vzorcov.citovat
#039509
avatar
No niečo som vymyslel. Predpokladám, že v bunke A1 nie je text.

=IF(MOD(A1;1)=0;A1/24/60;TEXT(A1;"[hh]:mm")/60)

=KDYŽ(MOD(A1;1)=0;A1/24/60;HODNOTA.NA.TEXT(A1;"[hh]:mm")/60)citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Výmaz řádku podle hodnoty v konkrétním sloupci

elninoslov • 7.2. 21:49

Výmaz řádku podle hodnoty v konkrétním sloupci

Alfan • 7.2. 14:02

Výmaz řádku podle hodnoty v konkrétním sloupci

Alfan • 7.2. 11:44

plán 12 h směn na celý rok

PE1PA • 6.2. 14:56

plán 12 h směn na celý rok

elninoslov • 6.2. 14:16

plán 12 h směn na celý rok

elninoslov • 6.2. 14:15

plán 12 h směn na celý rok

elninoslov • 6.2. 13:21