< návrat zpět

MS Excel


Téma: součet časů Incidentů rss

Zaslal/a 15.2.2018 8:14

Potřeboval bych poradit jak sečíst několik časů délky trvání Incidentů (časy jsou k jednomu jménu a typu zařízení různě v tabulce) a doplnit je do řádku prvního výskytu zařízení daného typu a jména.
Přikládám jak vzor tabulku s vyznačením kam je potřeba dostat souhrnný čas. Počet výskytů a rozdíl časů jsem nějak zvládnul.

Díky za pomoc.

Příloha: xlsx39540_incidenty_pokus_1.xlsx (12kB, staženo 31x)
Zaslat odpověď >

icon #039541
eLCHa
Když jste zvládl COUNTIFS, tak SUMIFS už by problém být neměl ;)citovat
#039542
avatar
@eLCHA děkuji.

Potřebuji, ale docílit toho, aby se mi časy z délek Incidentů pro jedno zařízení a jméno zařízení sečetlo, ale objevilo se pouze vždy u prvního výskytu v tabulce. Typ zařízení a jméno se může v tabulce opakovat několikrát, ale číslo Incidentu je vždycky jiné (jedinečný identifikátor). Pokud dám do sloupce sumifs a protáhnu vzorec přes všechny buňky, tak se mi při každém výskytu stejného zařízení a jména objeví stejný součet. Potřeboval bych, aby mi tento proces součtů fungoval vždy pouze u 1.výskytu jako souhrn všech další stejných výskytů.
Tak nevím jestli je to z popisu jasné. 6

Děkujicitovat
icon #039544
eLCHa
KT?
Příloha: xlsx39544_39540_incidenty_pokus_1.xlsx (16kB, staženo 28x)
citovat
#039546
elninoslov
?
=IF(COUNTIFS(G$2:G2;G2;F$2:F2;F2)=1;SUMIFS(D:D;G:G;G2;F:F;F2);"")
=KDYŽ(COUNTIFS(G$2:G2;G2;F$2:F2;F2)=1;SUMIFS(D:D;G:G;G2;F:F;F2);"")
citovat
#039563
avatar
@elninoslov dík funguje.

Jenom jsem narazil na problém jak od sebe odečíst dva datumy s časem v jedné buňce:
např. A1 01.02.2017 13:29 A2 07.02.2017 13:12
výsledek potřebuji dostat do A3. 8

Díkycitovat
#039565
avatar

Anonym napsal/a:

@elninoslov dík funguje.

Jenom jsem narazil na problém jak od sebe odečíst dva datumy s časem v jedné buňce:
např. A1 01.02.2017 13:29 A2 07.02.2017 13:12
výsledek potřebuji dostat do A3.

Díky

=A2-A1
A naformátuj na [hh]:mm:sscitovat
#039566
avatar
Proč si vždycky po obdržení odpovědi připadám jako úplný bl..c 6citovat
#039568
avatar

lafo napsal/a:

Proč si vždycky po obdržení odpovědi připadám jako úplný bl..c

Ak je aj toto otázka, tak fakt netuším. 2citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse