< návrat zpět

MS Excel


Téma: Sloučení textu z buněk rss

Zaslal/a 9.3.2018 15:25

Zdravím experty. Můžete mi poradit, jak spojit zdrojová data viz příloha? Mám několik stovek řádků. Každý blok je vždy oddělen prázdným řádkem. A samotný blok je několika-řádkový (3 až 6 řádků). Díky moc za radu.

Příloha: jpg39796_excel.jpg (37kB, staženo 43x)
39796_excel.jpg
Zaslat odpověď >

#039797
avatar
Zdravím, zarovnat do bloku. Na těch několik stovek řádků stačí několik málo kliků. Pozor na dostatečnou šířku sloupce.citovat
#039799
elninoslov
Ak je presne daná štruktúra, že sú spájané bloky od seba oddelené pravidlom "prázdny/neprázdny/prázdny" a zároveň majú veľkosť od 3 do 6 riadkov, tak do C3:
=IF(AND(A2="";A3<>"";A4<>"";A5<>"");A3&"#"&A4&"#"&A5&IF(AND(A6<>"";A5<>"");"#"&A6;"")&IF(AND(A7<>"";A6<>"");"#"&A7;"")&IF(AND(A8<>"";A7<>"");"#"&A8;"");"")

=KDYŽ(A(A2="";A3<>"";A4<>"";A5<>"");A3&"#"&A4&"#"&A5&KDYŽ(A(A6<>"";A5<>"");"#"&A6;"")&KDYŽ(A(A7<>"";A6<>"");"#"&A7;"")&KDYŽ(A(A8<>"";A7<>"");"#"&A8;"");"")

a potiahnuť dole.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse