< návrat zpět

MS Excel


Téma: Součet čísel v sobotu a v neděli rss

Zaslal/a 25.12.2018 21:12

ahojte, potřeboval bych od zkušenějších opět malou pomoc. Mám tabulku (sloupec A datumy, sloupec C čísla. Potřeboval bych nějak hromadně sečíst čisla v sloupci C, když je datum sobota nebo neděle. Dá se to bez maker a vba?

Přikládám i ukázkový soubor.

Díky za případnou pomoc

Dalibor

Příloha: rar42203_soucet-soboty-a-nedele.rar (8kB, staženo 22x)
Zaslat odpověď >

#042204
avatar
už asi vím 1 :

=SUMA(KDYŽ(DENTÝDNE(B1:B11)=7;C1:C11;0))+SUMA(KDYŽ(DENTÝDNE(B1:B11)=1;C1:C11;0))citovat
#042205
Stalker
Nebo maticově. Zadání vzorce se ukončí trojkombinací CTRL+SHIFT+ENTER
Příloha: xlsx42205_soucet-soboty-a-nedele.xlsx (10kB, staženo 26x)
citovat
#042206
avatar
Stalker, díky za info, ono to původně bylo maticově, jen jsem si nevšiml, že se to nekopíruje s těma závorkama 1 .

Ale i tak díky moccitovat
#042207
Stalker
jop, máš pravdu, ale v tom případě sem kratší 2citovat
#042208
avatar
Já jsem použil SUMIF, ale potřebuji k tomu pomocný sloupec.
Nešlo by to nějak bez něj?
Příloha: xlsx42208_42205_soucet-soboty-a-nedele-sumif.xlsx (11kB, staženo 23x)
citovat
#042209
avatar
=SOUČIN.SKALÁRNÍ(--(DENTÝDNE(A1:A14;2)>5);C1:C14)citovat
#042210
avatar
Hmm. Tuto funkci zatím obcházím obloukem. Ale asi na ni budu muset vlítnout.citovat
#042211
avatar
pro mě maticový vzorec a skalární součin vyjdou skoro na stejno, vlastně nevím, v čem by mohl být rozdíl, možný ve velkých výpočtech. Asi každý použite to, co mu lépe vyhovuje.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Chyba makro na MacOS

Alfan • 26.5. 18:25

Chyba makro na MacOS

elninoslov • 26.5. 17:33

Rozdělení dat z jednoho sešitu do více sešitů

Petr888 • 26.5. 11:18

Rozdělení dat z jednoho sešitu do více sešitů

elninoslov • 26.5. 10:41

Chyba makro na MacOS

Alfan • 26.5. 9:07

Rozdělení dat z jednoho sešitu do více sešitů

Petr888 • 26.5. 8:44

Rozdělení dat z jednoho sešitu do více sešitů

elninoslov • 25.5. 18:20