< návrat zpět

MS Excel


Téma: Doplneni prumeru rss

Zaslal/a 10.1.2019 5:48

ID Udaj
1 100
2
3 150
4
5 158
6 160
7
8
9
10
11 175
... ...

Ahoj, mám takto dva sloupce a potřebovala by jsem doplnit mezi údaje průměr z nejbližších hodnot a ten postupně přičítat k předchozímu číslu.
Děkuji

Zaslat odpověď >

#042371
MePExG
Zvláštne zadanie. Doplniť priemer medzi dve čísla to ešte chápem, je to zrozumiteľné, ak chýba jedno číslo. Neviem čo sa má stať, ak chýba viac čísiel (ID 7,8,9) a už som totálne mimo z požiadavky pripočítania.
Čo tak dať prílohu a vyplnený príklad riešenia?citovat
#042372
elninoslov
Iba nápad. Ale nepočíta sa s tým, že bude chýbať počiatočný alebo koncový údaj, a tiež sa počíta s tým, že sú hodnoty vzostupné, tak ako je v príklade.
=IF(B2<>"";B2;C1+(AVERAGE(MAX($C$1:$C1);MIN($B3:$B$12))-MAX($C$1:$C1)))

=KDYŽ(B2<>"";B2;C1+(PRŮMĚR(MAX($C$1:$C1);MIN($B3:$B$12))-MAX($C$1:$C1)))


EDIT: Vymenil som prílohu o 8:51, lebo som si uvedomil, že je nesprávna. :)citovat
#042377
avatar
A nebo se požaduje pouze lineárně vyplnit interval?
Pak by stačilo vybrat oblast od-do a VYPLNITcitovat
#042394
avatar
Ahoj,
děkuji za odpověďi.
Mezi nejbližší známé údaje se má doplnit průměr rozdílu těchto hodnot.

@elninoslov
ten vzorec ukazuje jine hodnoty když je dám do svého příkladu

V příloze je více.

Děkuji
Příloha: xlsx42394_2018.xlsx (30kB, staženo 18x)
citovat
#042396
elninoslov
No neviem, mňa napadá len takéto zložitejšie riešenie (nesedí nám spolu zaokrúhľovanie) :
=IF(B2<>"";B2;C1+(MIN($B3:$B$366)-MAX($B$1:$B2))/(MATCH(MIN($B3:$B$366);$B$1:$B$366;0)-MATCH(MAX($B$1:$B2);$B$1:$B2;0)))

=KDYŽ(B2<>"";B2;C1+(MIN($B3:$B$366)-MAX($B$1:$B2))/(POZVYHLEDAT(MIN($B3:$B$366);$B$1:$B$366;0)-POZVYHLEDAT(MAX($B$1:$B2);$B$1:$B2;0)))
citovat
#042400
avatar
Super,
děkuji velice, To zaokrouhlování je v pořádku, já měla na dvě desetiny a Vy máte na víc.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse