< návrat zpět

MS Excel


Téma: Součet 5 buněk ze 6ti s podmínkou rss

Zaslal/a 22.1.2019 14:28

Trápím se s jedním výpočtem. Mám 6 buněk A2 až A7 s číselnými hodnotami. Potřebuji do A1 získat součet 5ti buněk s nejvyšší hodnotou s podmínkami: pokud je vyplněno 1 až 5 buněk, prostý součet, pokud je ale vyplněno všech 6 buněk, potřebuji sečíst pouze 5 buněk s nejvyššími hodnotami (ignorovat buňku s nejnižší hodnotou). Zkoušel jsem large, ale to hází špatný vzorec při počtu hodnot méně než 5. Zkoušel jsem prostý součet mínus nejnižší hodnota, to ale funguje jen pro 6 vyplněných buněk, ne pro 5 a méně.
Mohu poprosit o pomoc pro excel 10? Předem díky lidi...

Zaslat odpověď >

#042487
avatar
Dotaz:
buňky se vyplňují postupně nebo mohou být napřeskáčku?
Např. dvě vyplněné buňky budou vždy A2 a A3 nebo může být A2 a A5.
Tři vyplněné buňky: vždy A2, A3, A4 nebo třeba A3, A5, A7 nebo A5,A6,A7?citovat
#042488
elninoslov
Overené:
maticový vzorec:
=SUM(IFERROR(LARGE(A2:A7;{1;2;3;4;5});0))
=SUMA(IFERROR(LARGE(A2:A7;{1;2;3;4;5});0))

nematicový vzorec
=SUMPRODUCT(IFERROR(LARGE(A2:A7;{1;2;3;4;5});0))
=SOUČIN.SKALÁRNÍ(IFERROR(LARGE(A2:A7;{1;2;3;4;5});0))

A ešte doplním možnosť, keď je počet čísel meniteľný v H1 (maticový vzorec):
=SUM(IFERROR(LARGE(A2:A7;ROW(OFFSET($A$1;;;H1)));0))
=SUMA(IFERROR(LARGE(A2:A7;ŘÁDEK(POSUN($A$1;;;H1)));0))
Příloha: xlsx42488_sucet-x-cisel.xlsx (11kB, staženo 18x)
citovat
#042505
avatar
Vyplňování buněk je postupné od A2 do A7. Omlouvám se za pozdní reakci a díky za navržená řešení, hned se jdu na to podívat...citovat
#042508
avatar
Tak jsem to odzkoušel, do matic jsem se nechtěl pouštět... U nematicových řešení ten první vzorec nefunguje - píše mi to "neznámý text" u SUMPRODUCT. Ale ten druhý vzorec =SOUČIN.SKALÁRNÍ(IFERROR(LARGE(A2:A7;{1;2;3;4;5});0)) funguje přesně, jak potřebuji. Odzkoušeno v různých situacích, perfektní! Moc děkuju, pomohl jste mi!citovat
#042509
avatar
elninoslov totiž píše vždy dvě verze. Jednu pro anglickou a slovenskou verzi excelu a druhou pro českou verzi excelu.

Tam kde všichni používají SUM, tak češi musí mít SUMA.

stejně tak SOUČIN.SKALÁRNÍ je počeštěný SUMPRODUCT

Když použijete ten maticový SUMA, tak stačí zkopírovat do bu%nky a stisknout ctrl+shift+enter, Klasickým "odentrováním" se neuloží maticově a pak nefunguje.citovat
#042516
avatar
Díky za vysvětlení, už je mi to jasné... Hezký den!citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse