< návrat zpět

MS Excel


Téma: Č. řádku na základě kritérií ve 2 sloupcích rss

Zaslal/a 23.1.2019 9:53

Dobrý den, prosím o pomoc se vzorcem. Výsledkem má být číslo řádku v tabulce nalezeného prvního výskytu shody kritérií ve 2 sloupcích.
Tedy modelová tabulka A1:B50, ve sloupci A číselné hodnoty, ve sloupci B textové hodnoty. Potřebuji určit číslo prvního řádku, kde se bude nacházet ve sloupci A hodnota 444 a současně ve sloupci B hodnota "ttt".V případě, kdy této podmínce neodpovídá žádný řádek tabulky, vrátí vzorec chybovou hodnotu.
Předem díky za pomoc.
Oprava zadání a upřesnění:
Ve sloupci A jsou kromě číselných hodnot i hodnoty typu "". Ve sloupci B jsou kromě textových hodnot i prázdné buňky. Vyhledávací kritérium může být také podmínka typu >0 (větší jak nula), čemuž odpovídá i hodnota "", to je ale nežádoucí.
Maticový vzorec níže funguje, ale jenom s konkrétními hodnatami kritérií.
{=POZVYHLEDAT("444"&ttt;A1:A50&B1:B50;0)}

Zaslat odpověď >

#042518
elninoslov
=IFERROR(MATCH(1;(A1:A50=D1)*(B1:B50=E1);0);"nenájdené")
=IFERROR(POZVYHLEDAT(1;(A1:A50=D1)*(B1:B50=E1);0);"nenájdené")
Příloha: xlsx42518_hladaj-riadok-podla-2-podmienok.xlsx (12kB, staženo 20x)
citovat
#042519
elninoslov
Príklad pre doplnené zadanie:
=IF(OR(D1="";E1="");"zadejte podmínky";IFERROR(MATCH(1;(A1:A50<>"")*(A1:A50=D1)*(B1:B50=E1);0);"nenájdené"))
=KDYŽ(NEBO(D1="";E1="");"zadejte podmínky";IFERROR(POZVYHLEDAT(1;(A1:A50<>"")*(A1:A50=D1)*(B1:B50=E1);0);"nenájdené"))


=IF(OR(D1="";E1="");"zadejte podmínky";IFERROR(MATCH(1;(A1:A50<>"")*(A1:A50>D1)*(B1:B50=E1);0);"nenájdené"))
=KDYŽ(NEBO(D1="";E1="");"zadejte podmínky";IFERROR(POZVYHLEDAT(1;(A1:A50<>"")*(A1:A50>D1)*(B1:B50=E1);0);"nenájdené"))
Příloha: xlsx42519_hladaj-riadok-podla-2-podmienok.xlsx (12kB, staženo 22x)
citovat
#042520
avatar
Ahoj,spoléhal jsem na tebe, Martine, moc díky. Aplikoval jsem vzorec do reálného řešení, viz níže, ale někde je tam bota, v této podobě to hází chybný výsledek.
=POZVYHLEDAT(1;(G11:G41="N")*(NEBO((AM11:AM41=NEPRAVDA);(AN11:AN41=NEPRAVDA)));0)
Ve sloupcích AM a AN jsou výsledky vzorců PRAVDA/NEPRAVDA a má se brát první výskyt hodnoty NEPRAVDA v jednom nebo druhém sloupci, a současně musí platit podmínka pro slouec G.
Prakticky jde o testování zapsaných hodnot, případně výsledků jiných vzorců a na základě nalezené "chyby" se má sáhnout pro varovné hlášení, uložené na určité adrese a zobrazit jej. Proto potřebuji extrahovat číslo řádku vyhovující zadaným podmínkám.citovat
#042522
elninoslov
Nie som si istý, či rozumiem, ale teda takto to nájde prvý výskyt nasledovných dvoch splnených podmienok (oboch naraz):
=MATCH(1;(G11:G41="N")*((AM11:AM41+AN11:AN41)<>2);0)
=POZVYHLEDAT(1;(G11:G41="N")*((AM11:AM41+AN11:AN41)<>2);0)

1. V stĺpci G je "N"
2. Aspoň v jednom zo stĺpcov AM alebo AN je FALSE/NEPRAVDA

Teda podmienka 2 je splnená v prípadoch : FALSE+FALSE, FALSE+TRUE, TRUE+FALSE

Ak ide v maticovom vzorci o operáciu OR/NEBO, nemôže sa použiť OR/NEBO, ale namiesto toho sa použije súčet, teda "+". A výsledok súčtu sa testuje. Keď je výsledok iný ako 0, tak je splnená aspoň jedna podmienka z OR/NEBO (výsledok je počet splnených).

Ak ani teraz nechápem zadanie, musíš asi priložiť súbor ... :)citovat
#042524
avatar
Pochopil jsi to správně. S log. součtem jsem to zkoušel i s "+" místo funkce NEBO, ale trochu jinak, a také mi to nefungovalo.
Tvůj vzorec mi ale taky nemaká, vrací: "CHYBA - hodnota není k dispozici!"
Soubor jsem ti poslal na mail.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Sumar nakupov

Pavlus • 22.1. 13:05

VBA - načtení dat ze souboru s proměnným názvem

Fantasyk • 22.1. 9:12

Sumar nakupov

Robo11 • 21.1. 21:23

VBA - načtení dat ze souboru s proměnným názvem

€Ł мσşqμΐτσ • 21.1. 12:21

Tělo emailu ve VBA - formát

Fantasyk • 20.1. 20:47

odstranenie opakujucich sa udajov v riadkoch

frantilopa • 20.1. 18:12

odstranenie opakujucich sa udajov v riadkoch

marjankaj • 20.1. 18:01