< návrat zpět

MS Excel


Téma: Nula vs ERROR rss

Zaslal/a 3.2.2019 10:28

zdravim vas,
vedeli by ste prosim niekto poradit s jednym suctovym vzorcom?

Napisal som vzorec, ktory bude z daneho stlpca pocitat len ciselne hodnoty a chyby bude ignorovat.
Avsak, ja by som ten vzorec potreboval upravit tak, ze ak by sa v stlpci nenachadzali ziadne hodnoty, tak v tom pripade nebude vysledok 0, ale vysledok bude chyba.
Cize akonahle.

Vzorec, ktory tam mam napisany vo vyznacenej bunke na obrazku je SUMIF(H20:H34;"<>#NEDOSTUPNÝ")

Da sa urobit nejaka takato uprava?
dakujem

Příloha: png42634_snimka.png.png (17kB, staženo 34x)
42634_snimka.png.png
Zaslat odpověď >

#042635
Stalker
Co takhle funkce NEDEF()?
V en excelu možná NA().citovat
#042636
elninoslov
Maticový vzorec:
=IF(COUNT(H20:H34)=0;NA();SUM(IFERROR(H20:H34;0)))
=KDYŽ(POČET(H20:H34)=0;NEDEF();SUMA(IFERROR(H20:H34;0)))
citovat
#042637
avatar
Tak som to skusil.
Je mozne, ze robim v tom vzorci nieco zle?
Lebo na tie nedostupne bunky to funguje, ale na tie, kde je to kombinacia cisel a chyby, tak tam rata nulu.
Ale ked otvorim funkciu, tak v nej ukazuje, ze vysledok by mal byt ciselny, cize 22316.
Příloha: png42637_snimka.png.png (42kB, staženo 29x)
42637_snimka.png.png
citovat
#042638
avatar
plus ten druhy obrazok
Příloha: png42638_snimka2.png.png (21kB, staženo 24x)
42638_snimka2.png.png
citovat
#042639
elninoslov
Nie ERF(1) ale ERF(1;), tak som to radšej nahradil NA(), A píšem maticový vzorec, nie normálny. Teda potvrdenie vzorca je Ctrl+Shift+Enter. Nie len Enter.
Příloha: xlsx42639_vzorec-na.xlsx (11kB, staženo 20x)
citovat
#042640
avatar
Pardon, nevedel som co je to maticovy vzorec - prvy krat o tom teraz citam na nete.
Kazdopadne, urobil som to teraz cez ctrl+shift+enter a uz to funguje ako ma :)
velmi pekne dakujem za pomoccitovat
#042670
avatar
Bez matic:
=KDYŽ(POČET(A2:A50)=0;NEDEF();AGGREGATE(9;6;A2:A50))citovat
#042674
avatar
funguje dobre, dakujem :)citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

přečíst platbu a zapsat

PavDD • 25.11. 14:02

Zrušení podmíněného formátovní vložením do funkc

Jiří497 • 25.11. 12:56

Vložení na první volnou buňku ve sloupci.

PavelJanec • 25.11. 9:05

Vložení na první volnou buňku ve sloupci.

PavelJanec • 25.11. 8:53

Zrušení podmíněného formátovní vložením do funkc

Krifry • 25.11. 8:52

Prvních 5

Fantasyk • 25.11. 3:57

Vložení na první volnou buňku ve sloupci.

elninoslov • 25.11. 0:45