< návrat zpět

MS Excel


Téma: Vlastní formát hmotnosti v buňce rss

Zaslal/a 11.2.2019 14:40

Vstup hmotnosti je v kilogramech, méně než 0,1 kg je zobrazeno v gramech, jinak v kg a více než 1000 kg v tunách.

Nedaří se mi sestavit Formát buňky => Vlastní, zkoušel jsem bez úspěchu sestavit limity v hranatých závorkách, nejspíš by musela být vstupní hodnota v gramech, nevěděl by někdo?

Pomocí vzorce:

=KDYŽ(A1<0,1;HODNOTA.NA.TEXT(A1*1000;"0")&" g/ks";KDYŽ(A1<1000;HODNOTA.NA.TEXT(A1;"0,0##")&" kg/ks";HODNOTA.NA.TEXT(A1/1000;"0,0##")&" t/ks"))


Lze nějak nastavit formát čísla na proměnlivý počet míst, aby není-li třeba desetinných míst zobrazoval celé číslo, jinak dle potřeby až tři desetinná místa?
"0,###" bohužel nechá desetinnou čárku za celým číslem.

Předem díky za případnou pomoc.

Zaslat odpověď >

Strana:  « předchozí  1 2
icon #042743
avatar
jj, proste miesto "" tam patri #citovat

Strana:  « předchozí  1 2

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

rozpis zápasů hráčů pro utkání dvou týmů

Anonym • 25.5. 11:54

Hromadné přepsání

elninoslov • 24.5. 10:29

Hromadné přepsání

Nomi • 24.5. 8:32

Index - každý rok začít od 1 Power Query

Alfan • 23.5. 9:17

nepřímý odkaz

elninoslov • 23.5. 0:00

nepřímý odkaz

bordov • 22.5. 18:35

vrácené hodnoty

Anonym • 22.5. 15:46