< návrat zpět

MS Excel


Téma: funkce KDYŽ rss

Zaslal/a 24.2.2019 15:26

Dobrý den/ahoj.
Prosím o pomoc.
Tento vzorec mi funguje pouze na podmínku "B" ale na ostatní již ne.....
Kde mám chybu?
Předem díky moc......

=KDYŽ(B9="B";1;0)*SUMA(D9*$K$1*0,5;KDYŽ(B9="O";1;0)*SUMA(D9*$K$1;KDYŽ(B9="K";1;0)*(D9*$K$1*0,75)))

Zaslat odpověď >

#042807
Stalker
4 To jako vážně?! Máš dojem, že se tu pohybují samý věštci a telepati?
Opravdu si myslíš, že na základě poskytnutých dat někdo dokáže zjistit případnou chybu bez znalosti jejich typu a struktury?
Pokud chceš opravdu poradit, přilož vzorový soubor, kde bude znázorněn požadovaný výsledek.citovat
#042813
avatar
Omlouvám se......
vzoreček potřebuji zapsat do buňky C9;
KDYŽ B9=B, tak násobit K1*D9*0,5; pokud B9=O, tak násobit K1*D9*1, pokud B9=K, tak násobit K1*D9/0,75citovat
#042814
Stalker
?=KDYŽ(B9="B";K1*D9*0,5;KDYŽ(B9="O";K1*D9*1;KDYŽ(B9="K";K1*D9/0,75;"")))citovat
#042815
avatar
Funguje.
Moc děkuji.citovat
#042819
elninoslov
Funguje ? O tom pochybujem. V prvom zadaní je *0,75, v druhom /0,75.
Ak by sa jednalo vždy o násobenie (a nie v treťom prípade o delenie), tak je možností kvantum, napr.:
=K1*D9*IF(B9="B";0,5;IF(B9="O";1;IF(B9="K";0,75;0)))
=K1*D9*KDYŽ(B9="B";0,5;KDYŽ(B9="O";1;KDYŽ(B9="K";0,75;0)))

ak by bolo násobkov väčšie množstvo, tak ďalej napr.:
=IFERROR(K1*D9*INDEX({0,5;1;0,75};MATCH(B9;{"B";"O";"K"};0));"")
=IFERROR(K1*D9*INDEX({0,5;1;0,75};POZVYHLEDAT(B9;{"B";"O";"K"};0));"")

=IFERROR(K1*D9*CHOOSE(MATCH(B9;{"B";"O";"K"};0);0,5;1;0,75);"")
=IFERROR(K1*D9*ZVOLIT(POZVYHLEDAT(B9;{"B";"O";"K"};0);0,5;1;0,75);"")

=IFERROR(K1*D9*INDEX({0,5;1;0,75};SEARCH(B9;"BOK"));"")
=IFERROR(K1*D9*INDEX({0,5;1;0,75};HLEDAT(B9;"BOK"));"")

Alebo prípadne, ako sa to bežne robí, je prevodná tabuľka hodnôt (v tomto prípade násobičov).

V každom prípade si ošetrite cez Overenie dát, možnosť zadať iba povolené hodnoty do B9.citovat
#042820
avatar
všude mám násobení.....
to dělení byl překlep.
vzoreček funguje a ověření dat mám též.
Děkuji za upozornění.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

rozpis zápasů hráčů pro utkání dvou týmů

Anonym • 25.5. 11:54

Hromadné přepsání

elninoslov • 24.5. 10:29

Hromadné přepsání

Nomi • 24.5. 8:32

Index - každý rok začít od 1 Power Query

Alfan • 23.5. 9:17

nepřímý odkaz

elninoslov • 23.5. 0:00

nepřímý odkaz

bordov • 22.5. 18:35

vrácené hodnoty

Anonym • 22.5. 15:46