< návrat zpět

MS Excel


Téma: Externí odkaz rss

Zaslal/a 25.2.2019 5:30

Potřebuji ze zavřeného sešitu získat text z určité buňky.
=SUMA('C:\prace\angebote\[f.xlsx]List1'!$A$1)

Tento vzorec mi funguje, pokud je v buňce A1 číslo. Já však potřebují načíst a přenést text, což bohužel nejde. Jako výsledek se vždy zobrazí 0.

Externí odkazy jsou tedy použitelné pouze u číselých hodnot? Pokud ano, lze to obejít nějakým jiným způsobem?

za postřehy děkuji

Zaslat odpověď >

#042825
avatar
Pokud chceš získat pouze text z buňky, tak proč je odkaz obalen funkcí SUMA? To je příčinou celého problému ;-)...

Nula se ti přes odkaz na buňku standardně zobrazí pouze v případě, že se odkazuješ na prázdnou buňku.
P.citovat
#042850
avatar
Díky za odpověď funguje to skvěle. V souvislosti s externím odkazem ale vyvstal další problém.

Pomocí VBA kódu nechám do sloupce A vypsat obsah konkrétní složky. Pomocí vzorce =KDYŽ(JE.PRÁZDNÉ(A2);"";HYPERTEXTOVÝ.ODKAZ($C$1&"\"&A2;ZLEVA(A2;DÉLKA(A2)-(DÉLKA(A2)-(NAJÍT(".";A2))+1)))) odstraním z názvu souborů přípony a vytvořím hypertextový odkaz na daný soubor (viz sloupec D). Po kliknutí na text ve sloupci D se tak otevře daný soubor. Doposud je vše sluncem zalité.

Nyní k věci. Do Buňky F2 manuálně vkládám externí odkaz na buňku ze sešitu uvedeného v buňce A2. Měl jsem myšlenku, že bych externí odkaz na buňku poskládal z jednotlivých částí - viz vzorec uvedený v buňce H2 a poté vzniklý text přeměnil na vzorec funkcí VYHODNOTIT, dle návodu na níže uvedeném odkazu. Bohužel, tento postup nefunguje (chybová hláška: neplatný odkaz na buňku). Má někdo nějaký tip na řešení? Pevně doufám, že jsem to napsal srozumitelně. Díky moc

https://www.itlektor.cz/microsoft-excel/prevod-textu-na-vzorec-v-excelu-funkci-evaluate/[/url

[img]https://i.ibb.co/F56z3br/snap1.jpg[/img]
#042851
avatar
přikládám přílohu (než jsem text dopsal, byl jsem bohužel automaticky odhlášen)
Příloha: jpg42851_snap1.jpg (169kB, staženo 41x)
42851_snap1.jpg
citovat
#042853
avatar
K tomuto doporučuji nastudovat funkce NEPŘÍMÝ.ODKAZ a ODKAZ.
P.citovat
#042863
avatar
Díky, ještě než se do toho pustím...je správná úvaha, že když souborů ve složce bude třeba 100 a další budou přibývat, tak načítání hodnot z buněk jiných sešitů bude trvat dlouho? Napadlo mě ještě jedno elegantnější řešení, díky kterému bych se tomuto načítání vyhnul.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

rozpis zápasů hráčů pro utkání dvou týmů

Anonym • 25.5. 11:54

Hromadné přepsání

elninoslov • 24.5. 10:29

Hromadné přepsání

Nomi • 24.5. 8:32

Index - každý rok začít od 1 Power Query

Alfan • 23.5. 9:17

nepřímý odkaz

elninoslov • 23.5. 0:00

nepřímý odkaz

bordov • 22.5. 18:35

vrácené hodnoty

Anonym • 22.5. 15:46