< návrat zpět

MS Excel


Téma: Svyhledat a VBA rss

Zaslal/a 27.1.2020 16:54

Ahoj,
mám list s tabulkou sledování normohodin .
Z docházky jsem si vygeneroval zdrojový soubor s odpracovanou dobou u každého zaměstnance za den.
Tento jsem vložil do listu data.
Klíčem pro spojení je osobní číslo.
Udělal jsem si makro ve kterém používám funkci
svyhledat .Takto jak to mám bych to musel udělat pro každý řádek na 31 dnů.
Lze to , prosím , vyřešit jinak a navíc o nějakou kontrolu , že Excel prošel celý zdroj.Moc děkuji za čas se tímto zabývat . Stana V.

Příloha: zip45698_sledovani-normohodin.zip (59kB, staženo 20x)
Zaslat odpověď >

#045699
elninoslov
Dajte tento vzorec do B5, tú B5 dajte kopírovať, označte B5:AH32, pravý klik, Možnosti prilepenia - Vzorce.
=IF($A5="";"";VLOOKUP($A5;data!$B$2:$AJ$26;COLUMN(C5)))
=KDYŽ($A5="";"";SVYHLEDAT($A5;data!$B$2:$AJ$26;SLOUPEC(C5)))

Ale. Veď tie údaje v "Prosinec" sú potom kópia údajov v "data". Veď ich teda rovno vložte ako hodnoty do Prosinec. Alebo len nerozumiem potrebe mať presne rovnaké údaje v 2 listoch.
Ďalšia vec je, či Vy v Prosinec máte zoznam jedinečných ID (osobných čísel), alebo aj ten potrebujete tvoriť. A s tým suvisí aj to, či sa môže v "data" vyskytovať viackrát riadok s rovnakým ID - potom na hodnoty použiť SUMIF.

Zatiaľ nieje potrebné použiť makro.citovat
#045700
Stalker
Netuším proč zrovna trváš na vkládání vzorce přes VBA, ale budiž.
Příloha: zip45700_sledovani-normohodin.zip (59kB, staženo 25x)
citovat
#045702
avatar
Díky moc makro funguje bezvadně a ještě jednou dík za váš čas.
Potřeboval jsem to nějak načíst ze zdroje a mistr dál upravuje ještě hodiny na tom středisku dle toho zda člověk odpracoval celou směnu nebo byl v průběhu ještě přesunut jinam.
Hodně nám to ulehčí prvotní pořízení dat a pak už si děláme jen korekce.
Dosud jsme to pořizovali ručně a toto je jen jedno středisko máme jich 6. Ještě jedou děkuji a mějte se hezky. SVcitovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse