< návrat zpět

MS Excel


Téma: vyhladavacie funkcie rss

Zaslal/a 15.2.2020 19:49

Dobrý deň, potreboval by som pomoc so vzorcami v priloženom xls. Mám dochádzku a potrebujem si vyrobiť toolik, ktorý by mi kontroloval, či mám obsadené v každom tíme zmeny tak, že jeden z dvojice v tíme má rannú a druhý poobednú. Môj problém je, že excel prestane kontrolovať druhého v tíme, neviem ako na to. Zrejme funkcia offset by pomohla, ale neviem ako. Ďakujem za každú radu.

Příloha: xlsx45892_tool.xlsx (19kB, staženo 23x)
Zaslat odpověď >

#045897
elninoslov
Vyskúšajte či je toto správne (maticovo Ctrl+Shift+Enter):
=IF(SUM(COUNTIFS($B$21:$B$35;$B3;$C$21:$C$35;C$2;INDEX(Dochadzka;;MATCH($A$1;$E$18:$M$18;0));INDIRECT($A3)&"*"));"OK";"NOK")
=KDYŽ(SUMA(COUNTIFS($B$21:$B$35;$B3;$C$21:$C$35;C$2;INDEX(Dochadzka;;POZVYHLEDAT($A$1;$E$18:$M$18;0));NEPŘÍMÝ.ODKAZ($A3)&"*"));"OK";"NOK")
Příloha: xlsx45897_45892_tool.xlsx (20kB, staženo 28x)
citovat
#045903
avatar
Ďakujem,je to funkčné. Všetky funkcie poznám, ale takto v kombinácii im nerozumiem. Mal by som asi sto otázok k tomu, ako ten vzorec vlastne funguje :). Ďakujemcitovat
#045905
elninoslov
Ale veď ono to je vlastne jednoduché. INDEX+MATCH zabezpečí výber stĺpca s požadovaným dátumom. COUNTIFS vyberie z neho iba riadky spĺňajúce pracovnú pozíciu podľa B a tím podľa riadku 2. A potom príde to čaro, že COUNTIFS ako podmienku pre spĺňajúce riadky daného stĺpca, otestuje či začínajú na písmená smeny uvedenej v A ako názov oblasti smeny. Maticový vzorec to musí byť práve preto aby COUNTIFS testoval a vrátil toľko výsledkov, koľko je parametrov v danej smene, teda 5. Týchto 5 výsledkov bude vždy vyzerať tak, že budú 4x0 a 1x1, lebo bude daná bunka začínať práve jedným označením smeny. Preto to musíme potom zrátať cez SUM. A buď dostaneme 0 alebo 1.

EDIT:
Ešte ma napadlo, aby to nebol maticový vzorec ale normálny, stačí vymeniť SUM/SUMA za SUMPRODUCT/SOUČIN.SKALÁRNÍ.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Oddělovač polí

Milan-158 • 1.3. 16:01

Oddělovač polí

Whooocak • 1.3. 15:14

Vkládání dat z formuláře na zamknutém listu.

Milan-158 • 1.3. 15:12

Vlastne planovanie zmien

Anonym • 1.3. 7:56

Vkládání dat z formuláře na zamknutém listu.

Začátečník • 28.2. 19:34

Vkládání dat z formuláře na zamknutém listu.

Zdenys84 • 28.2. 19:05

Vkládání dat z formuláře na zamknutém listu.

Zdenys84 • 28.2. 19:00