< návrat zpět

MS Excel


Téma: Stejná podmínka různé možnosti rss

Zaslal/a 29.4.2020 22:51

Zdravím
Nevím jestli nadpis úplně vystihuje problém 1
Jde o to aby "hodnota 1" buď zůstala nebo se změnila na základě hodnoty 2
Z přílohy si myslím že to bude pochopitelnější.

Děkuji V.

Příloha: xlsx46529_podminka.xlsx (10kB, staženo 22x)
Zaslat odpověď >

Strana:  1 2   další »
#046530
avatar
A čo má byť pochopiteľnejšie? 4citovat
#046531
avatar
Nepochybně 5 5 5citovat
#046532
avatar
Zkusím to popsat
mohou nastat dvě situace možnost 1a a 1b (řádky 2a 3) nebo možnost 2a a 2b (řádky 4 a 5)
pokud je ve sloupcích B-C kombinace hodnot 3-1 a 4-0 zůstává u první (sl.výstup) hodnota 3 u druhé 4

pokud je ve sloupcích B-C kombinace 3-0 a 4-1 mění se hodnota 3 na 4 a hodnota 4 na 3

Snad to takhle bude lepší 7

edit:
a mě jde o to pokud bych dal vedle nějaký vzorec, který bude brát v úvahu pouze buňky v té samé řádce a rozkopíruju ho aby mi vrátil stejné hodnoty jako jsou ve sloupci výstupcitovat
#046533
avatar
Takto nejako? 2
Příloha: xlsx46533_kopia-46529_podminka-1.xlsx (9kB, staženo 19x)
citovat
#046534
avatar

marjankaj napsal/a:

Takto nejako?

takto právě ne, ve vzorci jsou použity buňky z jiných řádků než ve kterém je řádek napsán
Možná je to i logický nesmysl, nevím, proto jsem vznesl požadavek.
Trochu jsem ještě poupravil vzorový soubor. Hodnoty 2 sl.C budou neměnné ale Hodnoty 1 sl.B mohou mít i jiné kombinace např.5-6
Příloha: xlsx46534_podminka.xlsx (11kB, staženo 17x)
citovat
#046535
avatar
Pochopil jsem to takto:
první řádek
- 1 ve sloupci C nechá hodnotu ze sloupce B
- 0 ve sloupci C zvýší B o jedničku
druhý řádek
- 1 ve sloupci C sníží B o jedničku
- 0 ve sloupci C nechá hodnotu ze sloupce B

=KDYŽ(C2=1;B2;KDYŽ(C2=0;B2+1;"chybný vstup"))
=KDYŽ(C3=0;B3;KDYŽ(C3=1;B3-1;"chybný vstup"))
citovat
#046536
avatar

Jiří497 napsal/a:

Pochopil jsem to takto:

Výsledek je sice správně, ale jsou použity dva různé vzorce.
Je vůbec možné to udělat jedním?citovat
#046537
avatar
tak jsem použil řešení pomocí PowerQuery
viz. příloha
Příloha: xlsx46537_podminka_pq.xlsx (20kB, staženo 20x)
citovat
#046539
elninoslov
=B2+IF(MOD(ROW();2)=0;C2=0;-1*C2)
=B2+KDYŽ(MOD(ŘÁDEK();2)=0;C2=0;-1*C2)

Vaše zadanie je veľmi zlé. Vy asi viete, čo potrebujete, no neviete sa správne pýtať.

Ak je 1 riadok x a druhý y, tak nemôže platiť y=x+1, keď tvrdíte, že sa nemajú použiť bunky iného riadku.

Jiří497:
"chybný vstup" ??? Ako môže nastať tento stav, keď veny tvrdí, že je C nemenný a obsahuje 0 alebo 1? Či myslíte na prázdne ešte nezadané bunky?

EDIT: prípadne to ešte trošku skrátiť o 2 znaky :)
=B2+IF(MOD(ROW();2);-1*C2;C2=0)
=B2+KDYŽ(MOD(ŘÁDEK();2);-1*C2;C2=0)
citovat
#046540
avatar

elninoslov napsal/a:


Vaše zadanie je veľmi zlé. Vy asi viete, čo potrebujete, no neviete sa správne pýtať.

No nevěděl jsem jak se na to jinak zeptat - omluva 7

elninoslov napsal/a:


Ak je 1 riadok x a druhý y, tak nemôže platiť y=x+1, keď tvrdíte, že sa nemajú použiť bunky iného riadku.

tím jsem chtěl jen naznačit že hodnota 1 ve druhém řádku je vždy o jednu větší
Dle Vašeho funkčního vzorce si uvědomuji že je to nepodstatné

Děkuji moc
V.citovat

Strana:  1 2   další »

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

excell uprava riadku vzorca

orangezradca • 13.6. 20:37

pomala tlac s exelu

jano5 • 12.6. 9:44

GRAF teploty

JoKe • 12.6. 9:22

Filtrování dat

Imh0tep • 12.6. 8:35

Filtrování dat

Lader • 11.6. 23:22

Filtrování dat

Imh0tep • 11.6. 21:15

Zjištění směny dle data a času

Ontik • 11.6. 14:23