< návrat zpět

MS Excel


Téma: Smazat nuly na konci buňky rss

Zaslal/a 12.6.2020 22:23

FantasykZdravím hackeři 1 ,
už mi došly nápady...
Potřeboval bych smazat nuly na konci buňky..
Př. 1023000 nebo 205000 nebo 999500
a potřeboval bych, aby to pokaždé mazalo ( nebo skrylo ) jen nuly na konci..

Dík za radu

Zaslat odpověď >

Strana:  1 2 3   další »
#046893
avatar
Taková blbost, když těch nul nebude na konci moc.
Aneb jak trávit dlouhé zimní večery vnořováním dalších a dalších a dalších... když:
=KDYŽ(MOD(A2;10);A2;KDYŽ(MOD(A2;100);A2/10;KDYŽ(MOD(A2;1000);A2/100;KDYŽ(MOD(A2;10000);A2/1000;"Konec")))) 5
Musí se samozřejmě jednat o číslo.citovat
#046895
Fantasyk

Jiří497 napsal/a:

Taková blbost, když těch nul nebude na konci moc.
Aneb jak trávit dlouhé zimní večery vnořováním dalších a dalších a dalších... když:
=KDYŽ(MOD(A2;10);A2;KDYŽ(MOD(A2;100);A2/10;KDYŽ(MOD(A2;1000);A2/100;KDYŽ(MOD(A2;10000);A2/1000;"Konec"))))
Musí se samozřejmě jednat o číslo.


Jedná se jen o 2,3 nebo 4 nuly a když mám teď vzoreček:
=KDYŽ(JE.PRÁZDNÉ(B5);" ";SVYHLEDAT(B5;Zpian!F6:AC9999;5;0))

jak teď tam vložím ty když pro 2,3 a 4 nuly :-(

Ten tvuj vzorec funguje, ale nějak se mi nedaří ho vložit do toho mého 6
jedná se vždy čísla jen v tomto formátu... (1023000 nebo 205000 nebo 999500)

Díkycitovat
#046896
avatar
=A1/10^LEN(A1)*10^MAX(0;LEN(A1/10^LEN(A1))-2)
=A1/10^délka(A1)*10^MAX(0;délka(A1/10^délka(A1))-2)
Příloha: xlsx46896_xxx.xlsx (10kB, staženo 19x)
citovat
#046897
Fantasyk

marjankaj napsal/a:

=(A1/10^(LEN(A1)-1))*10^(LEN(A1/10^(LEN(A1)-1))-2)
=(A1/10^(délka(A1)-1))*10^(délka(A1/10^(délka(A1)-1))-2)

ten mi nejde vůbeccitovat
#046898
avatar
Příloha, příloha, příloha.......citovat
#046900
avatar

Jiří497 napsal/a:

Příloha, příloha, příloha.......

A nedal som?citovat
#046901
Fantasyk

marjankaj napsal/a:

Jiří497 napsal/a:Příloha, příloha, příloha.......
A nedal som?

Už jsem to stáhl.. jo to funguje, ale nějak mi nejde když chci spojit tyto dva vzorečky...
KDYŽ(JE.PRÁZDNÉ(B5);" ";SVYHLEDAT(B5;Zpian!F6:AC9999;5;0))
a to tvoje nebo od Jíří497 :-(

=KDYŽ(JE.PRÁZDNÉ(B5);" ";SVYHLEDAT(B5;Zpian!F6:AC9999;5;0))
a k tomu přidat...
(E5/10^(DÉLKA(E5)))*10^MAX(0;(DÉLKA(E5/10^(DÉLKA(E5)))-2)
Díkcitovat
#046902
avatar

marjankaj napsal/a:

Jiří497 napsal/a:Příloha, příloha, příloha.......
A nedal som?


To bylo na Fantastyk. Že by mohl dát přílohu s tím co mu nefunguje.citovat
#046906
Fantasyk

Jiří497 napsal/a:

marjankaj napsal/a:Jiří497 napsal/a:Příloha, příloha, příloha.......
A nedal som?

To bylo na Fantastyk. Že by mohl dát přílohu s tím co mu nefunguje.

Jiří497 napsal/a:

marjankaj napsal/a:Jiří497 napsal/a:Příloha, příloha, příloha.......
A nedal som?

To bylo na Fantastyk. Že by mohl dát přílohu s tím co mu nefunguje.

Napisu jak dojdu do prace k večerucitovat
#046907
Fantasyk
Soubor v příloze.

a potřebuji to dostat do E5 až E31, L5- L31,Q5 - Q31,V5 - V31

prostě , aby se nezobrazili ty nuly na konci 7

nejlepší by bylo Jiří asi to tvoje
Příloha: xlsx46907_vyroba-lisy-14.6-b-a-test.xlsx (143kB, staženo 24x)
citovat

Strana:  1 2 3   další »

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

rozpis zápasů hráčů pro utkání dvou týmů

Anonym • 25.5. 11:54

Hromadné přepsání

elninoslov • 24.5. 10:29

Hromadné přepsání

Nomi • 24.5. 8:32

Index - každý rok začít od 1 Power Query

Alfan • 23.5. 9:17

nepřímý odkaz

elninoslov • 23.5. 0:00

nepřímý odkaz

bordov • 22.5. 18:35

vrácené hodnoty

Anonym • 22.5. 15:46