< návrat zpět

MS Excel


Téma: Smazat nuly na konci buňky rss

Zaslal/a 12.6.2020 22:23

FantasykZdravím hackeři 1 ,
už mi došly nápady...
Potřeboval bych smazat nuly na konci buňky..
Př. 1023000 nebo 205000 nebo 999500
a potřeboval bych, aby to pokaždé mazalo ( nebo skrylo ) jen nuly na konci..

Dík za radu

Zaslat odpověď >

Strana:  « předchozí  1 2 3   další »
#046908
avatar
Třeba takto:
=KDYŽ(JE.PRÁZDNÉ(B5);" "; SVYHLEDAT(B5; ZPIAN!$F$6:$AC$10001;5;0)/10^délka(SVYHLEDAT(B5; ZPIAN!$F$6:$AC$10001;5;0))*10^MAX(0;délka(SVYHLEDAT(B5; ZPIAN!$F$6:$AC$10001;5;0)/10^délka(SVYHLEDAT(B5; ZPIAN!$F$6:$AC$10001;5;0)))-2)) 9
Příloha: xlsx46908_46907_vyroba-lisy-14.6-b-a-test.xlsx (135kB, staženo 16x)
citovat
#046909
Fantasyk

Jiří497 napsal/a:

Třeba takto:
=KDYŽ(JE.PRÁZDNÉ(B5);" "; SVYHLEDAT(B5; ZPIAN!$F$6:$AC$10001;5;0)/10^délka(SVYHLEDAT(B5; ZPIAN!$F$6:$AC$10001;5;0))*10^MAX(0;délka(SVYHLEDAT(B5; ZPIAN!$F$6:$AC$10001;5;0)/10^délka(SVYHLEDAT(B5; ZPIAN!$F$6:$AC$10001;5;0)))-2)) Příloha: 46908_46907_vyroba-lisy-14.6-b-a-test.xlsx (135kB, staženo 1x)


Parada ty jsi ale hlava :-)
akurát mi nejde třeba když se v listu Zpian oběví např kód 1078500 tak se mi ukáže 1078 7citovat
#046910
avatar
Ve vzorovém příkladu se číslo 1078500 nevyskytuje, jen 1078000.
Pokud tam 1078500 dopíšu, tak se v pořádku transformuje na 10785.citovat
#046911
Fantasyk

Jiří497 napsal/a:

Ve vzorovém příkladu se číslo 1078500 nevyskytuje, jen 1078000.
Pokud tam 1078500 dopíšu, tak se v pořádku transformuje na 10785.

aha moje chyba... a šlo by, aby se vždy mazali max 3 nuly ?
př. 910000 a zobrazilo by se 910 ?
př.2 1080000 a zobrazilo by se 1080 ?

Díky moccitovat
#046912
elninoslov
Namiesto tej 0 vo funkcii MAX tam dajte ešte obmedzenie
...
LEN(VLOOKUP(B5; Zpian!$F$6:$AC$10001;5;0))-3
...


EDIT:
Ak tomu dobre rozumiem, malo by stačiť podľa inšpirácie marjankaj aj kratšie:
=IF(ISBLANK(B5);" "; VLOOKUP(B5; Zpian!$F$6:$AC$10001;5;0)/10^(3-MAX(0;LEN(VLOOKUP(B5; Zpian!$F$6:$AC$10001;5;0)/10^3)-5)))
=KDYŽ(JE.PRÁZDNÉ(B5);" "; SVYHLEDAT(B5; Zpian!$F$6:$AC$10001;5;0)/10^(3-MAX(0;LEN(SVYHLEDAT(B5; Zpian!$F$6:$AC$10001;5;0)/10^3)-5)))


Teda pre názornosť marjankajov vzorec po úprave:
=A1/10^(3-MAX(0;LEN(A1/10^3)-5))
=A1/10^(3-MAX(0;DÉLKA(A1/10^3)-5))

opravte ma prosím ak sa mýlim.

EDIT 2:
Tak opravujem sa sám, môj predošlý vzorec je na prd, vracia zlé výsledky, ak je číslo bez núl kratšie ako 7 alebo ak je číslo s nulami kratšie ako 5.

každopádne Marjankajove riešenie funguje bezchybne. Upravené iba na 3 nuly:
=A1/10^LEN(A1)*10^MAX(LEN(A1)-3;LEN(A1/10^LEN(A1))-2)
=A1/10^DÉLKA(A1)*10^MAX(DÉLKA(A1)-3;DÉLKA(A1/10^DÉLKA(A1))-2)


Teda Váš vzorec bude
=VLOOKUP(B5; Zpian!$F$6:$AC$10001;5;0)/10^LEN(VLOOKUP(B5; Zpian!$F$6:$AC$10001;5;0))*10^MAX(LEN(VLOOKUP(B5; Zpian!$F$6:$AC$10001;5;0))-3;LEN(VLOOKUP(B5; Zpian!$F$6:$AC$10001;5;0)/10^LEN(VLOOKUP(B5; Zpian!$F$6:$AC$10001;5;0)))-2)
=SVYHLEDAT(B5; Zpian!$F$6:$AC$10001;5;0)/10^DÉLKA(SVYHLEDAT(B5; Zpian!$F$6:$AC$10001;5;0))*10^MAX(DÉLKA(SVYHLEDAT(B5; Zpian!$F$6:$AC$10001;5;0))-3;DÉLKA(SVYHLEDAT(B5; Zpian!$F$6:$AC$10001;5;0)/10^DÉLKA(SVYHLEDAT(B5; Zpian!$F$6:$AC$10001;5;0)))-2)

Končím "výskum" 1citovat
#046914
avatar
Jednoduše:
=KDYŽ(JE.ČISLO(A1);A1/10^(POZVYHLEDAT(0;MOD(A1;10^(ŘÁDEK(NEPŘÍMÝ.ODKAZ("A1:A4"))-1)))-1);"")
(maticově)citovat
#046915
elninoslov
Perfiš. A aj to sa dá zjednodušiť a odmaticovieť:
=IF(ISNUMBER(A2);A2/10^(MATCH(0;MOD(A2;10^{0;1;2;3}))-1);"")
=KDYŽ(JE.ČISLO(A2);A2/10^(POZVYHLEDAT(0;MOD(A2;10^{0;1;2;3}))-1);"")
citovat
#046922
Fantasyk
Děkuji všem, ale stejak mi to pořád nějak nejde 7

teď mám vzorec:
=KDYŽ(JE.PRÁZDNÉ(C21);" "; SVYHLEDAT(C21; Zpian!$F$6:$AC$10001;5;0)/10^DÉLKA(SVYHLEDAT(C21; Zpian!$F$6:$AC$10001;5;0))*10^MAX(0;DÉLKA(SVYHLEDAT(C21; Zpian!$F$6:$AC$10001;5;0)/10^DÉLKA(SVYHLEDAT(C21; Zpian!$F$6:$AC$10001;5;0)))-2))

a dopsal by jste mi někdo u něho aby to ubíralo max 3 nuly ?
viz příloha

a pak tam mám ještě makro, které pokaždé klikne na buňka a dá enter ( tlačítko ZAP. v buňce A35 ) aby se mi aktualizoval součet barev pozadí - nevíte jak by se to udělat jinak a lépe

Děkuji všem moc za ochotu
Příloha: zip46922_vyroba-lisy-14.6-b-a-test.xlsm.zip (138kB, staženo 16x)
citovat
#046927
elninoslov
Vidím, že v legende sa počíta s chybou (text ##### - chyba NEDOSTUPNÝ). Aj stĺpec UL. Takže aj v stĺpci MIX sa má zobraziť "#####" ak nenájde v Zpian? Alebo má byť potom bunka ="" ?
Makro na počítanie farby .... moje nervy, čo týždeň, to chce niekto spočítavať počet farieb. Na to Excel nieje stavaný. Zmena farby nespôsobí prepočet vzorcov, a teda na to ani makro nereaguje. Mám rozpracovanú celkom sľubnú metódu, ktorá by mala reagovať na zmenu farby, bez potreby niekam klikať, no zatiaľ nefunguje správne. Zmierte sa s potrebou aktualizácie počtu. Akurát asi nieje potrebné aby sa volala vo Vašom prípade makro funkcia pre každú bunku, ale iba jedna pre celý rozsah A5:A34 a pre všetky 3 farby naraz, a len do 1 bunky C35. Mám to tak urobiť?

EDIT: To s vypísaním chyby som pridal do stĺpca AC.
Makro som zmenil, Indexov farieb môžete do funkcie zadať variabilný počet. Tlačítko aktualizuje počet. Ak ste indexy farieb nepoužívali aj na niečo iné, stĺpec B nieje potrebný.
Příloha: zip46927_vyroba-lisy-14.6-b-a-test.zip (140kB, staženo 15x)
citovat
#046928
Fantasyk

elninoslov napsal/a:

Vidím, že v legende sa počíta s chybou (text ##### - chyba NEDOSTUPNÝ). Aj stĺpec UL. Takže aj v stĺpci MIX sa má zobraziť "#####" ak nenájde v Zpian? Alebo má byť potom bunka ="" ?
Makro na počítanie farby .... moje nervy, čo týždeň, to chce niekto spočítavať počet farieb. Na to Excel nieje stavaný. Zmena farby nespôsobí prepočet vzorcov, a teda na to ani makro nereaguje. Mám rozpracovanú celkom sľubnú metódu, ktorá by mala reagovať na zmenu farby, bez potreby niekam klikať, no zatiaľ nefunguje správne. Zmierte sa s potrebou aktualizácie počtu. Akurát asi nieje potrebné aby sa volala vo Vašom prípade makro funkcia pre každú bunku, ale iba jedna pre celý rozsah A5:A34 a pre všetky 3 farby naraz, a len do 1 bunky C35. Mám to tak urobiť?


#### tam jsou správně...

Makro:
Ano, pokud by šlo udělat ať označí a dá enter u všech najednou bylo by lepší...

EDIT:
abych to bylo jednodušší tak bych potřeboval:
=KDYŽ(JE.ČISLO(A2);A2/10^(POZVYHLEDAT(0;MOD(A2;10^{0;1;2;3}))-1);"")

a místo A2 dát:
KDYŽ(JE.PRÁZDNÉ(C21);" "; SVYHLEDAT(C21; Zpian!$F$6:$AC$10001;5;0)

ale nějak pokus omyl se mi to tam nedaří vecpatcitovat

Strana:  « předchozí  1 2 3   další »

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

rozpis zápasů hráčů pro utkání dvou týmů

Anonym • 25.5. 11:54

Hromadné přepsání

elninoslov • 24.5. 10:29

Hromadné přepsání

Nomi • 24.5. 8:32

Index - každý rok začít od 1 Power Query

Alfan • 23.5. 9:17

nepřímý odkaz

elninoslov • 23.5. 0:00

nepřímý odkaz

bordov • 22.5. 18:35

vrácené hodnoty

Anonym • 22.5. 15:46