< návrat zpět

MS Excel


Téma: Kontrola dat - číslo na 2 desetinná místa rss

Zaslal/a 18.8.2020 17:28

Dobrý den,

potřeboval bych poradit, jak udělat v kontrole dat nejspíš vlastní vzorec, že vkládané číslo má jen 2 desetinná místa.

Př. Pokud se vloží 4999,9999, tak excel zaokrouhlí na 5000,00. Cílem je, aby zadavatel dat si "usekl" cenu a vloží pak číslo 4999,99, tedy musí se kontrolovat, že se vkládá číslo na max 2 desetinná místa. Číslo se nesmí zaokrouhlovat. A nesmí se použít makro.

Příloha: xlsx47714_kontrola-dat-2-desetinna-mista.xlsx (10kB, staženo 14x)
Zaslat odpověď >

#047715
MePExG
V prílohe.
Příloha: xlsx47715_kontrola-dat-2-desetinna-mista.xlsx (21kB, staženo 38x)
citovat
#047716
avatar
Moc děkuji za řešení. 1
Jen si dovolím poznamenat, že vzorec v obrázku nefunguje, ale funguje vzorec, který je v ověření dat:
=A2*100-CELÁ.ČÁST(A2*100)=0

mepexg napsal/a:

V prílohe.Příloha: 47715_kontrola-dat-2-desetinna-mista.xlsx (21kB, staženo 11x)
citovat
#047719
avatar

MilaF napsal/a:

Moc děkuji za řešení.
Jen si dovolím poznamenat, že vzorec v obrázku nefunguje, ale funguje vzorec, který je v ověření dat:
=A2*100-CELÁ.ČÁST(A2*100)=0


ENG a CZ verze Excelucitovat
#047725
avatar
Tak jsem našel chybu ve vzorci a nechápu důvod.
Hodnoty od 1,09 do 1,16 nejdou vložit. Poradíte, prosím, proč a jak opravit?

=A2*100-CELÁ.ČÁST(A2*100)=0citovat
#047728
avatar
=A2*100=CELÁ.ČÁST(A2*100)
alebo
=A2=USEKNOUT(A2;2)citovat
#047737
avatar
Děkuji. Vypadá to, že funguje. 1citovat
#047742
avatar

MilaF napsal/a:

Děkuji. Vypadá to, že funguje.

Teší ma, že to tak vypadá. 10citovat
#047956
avatar
Dobrý den všem,

rád bych požádal o pomoc s funkčním vzorcem K4*100=CELÁ.ČÁST(K4*100) na kontrolu vkládaných dat na 2 desetinná místa.
Snažím se tento vzorec zahrnout do podmínky v sloupci K, ale z nějakého důvodu je tato kontrola na 2 desetinná místa excelem ignorována. Nechápu proč.
=KDYŽ(I4="";"";A(K4*100=CELÁ.ČÁST(K4*100);(USEKNOUT((K4/(1+I4/100)/1,25);2))<=(USEKNOUT((USEKNOUT((J4/1,25/(1+I4/100));2))*1,03;2))))

Kontrola vkládaných dat musí fungovat následovně:
Pokud je I prázdné, pak nesmí dát nic vložit (napsat upozornění "vložte DPH do sloupce I")
Pokud je I a J vyplněné, pak umožnit vložit data do K tak, že musí současně dále platit:
- číslo v K musí být max na 2 desetinná místa, nesmí se zaokrouhlovat - zde je funkční vzorec =K4*100=CELÁ.ČÁST(K4*100)
- když od K odečtu DPH a marži 25% a toto celé useknu na 2 desetinná místa, pak musí být menší nebo rovno hodnotě v P
Poradí, prosím někdo?
Příloha: xlsx47956_k-kontrola-dat-na-2-desetinna-mista.xlsx (53kB, staženo 15x)
citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

rozpis zápasů hráčů pro utkání dvou týmů

Anonym • 25.5. 11:54

Hromadné přepsání

elninoslov • 24.5. 10:29

Hromadné přepsání

Nomi • 24.5. 8:32

Index - každý rok začít od 1 Power Query

Alfan • 23.5. 9:17

nepřímý odkaz

elninoslov • 23.5. 0:00

nepřímý odkaz

bordov • 22.5. 18:35

vrácené hodnoty

Anonym • 22.5. 15:46