< návrat zpět

MS Excel


Téma: Svyhledat s proměnnou - název listu rss

Zaslal/a 5.1.2021 12:45

Ahoj,

mám 3 listy se stejnym formatem tabulek a potom list s názvem výkaz, na kterém bych potřeboval mít svyhledat s proměnným názvem listu, tzn, že v listu vykaz v bunce B2 vyberu první list a svyhledat by se mi změnil název listu ze kterého to hledá.
Např.
=VLOOKUP(C6;Druhy!A:R;18;0) po změně buňky B2 by byl =VLOOKUP(C6;Prvni!A:R;18;0)

Jde to nějak udělat nebo to excel neumi? Oblast pro svyhledat bude stale stejna, jen bude jiný list

Děkuji

Příloha: xlsx49357_test_promenna-nazev-listu.xlsx (16kB, staženo 12x)
Zaslat odpověď >

#049358
avatar
Pokud se jedná jen o 3 listy tak bych použil KDYŽ
=KDYŽ($B$2="Prvni"; SVYHLEDAT(C6;Prvni!A:R;18;0);KDYŽ($B$2="Druhy";SVYHLEDAT(C6;Druhy!A:R;18;0);SVYHLEDAT(C6;Treti!A:R;18;0)))citovat
#049359
avatar
Třeba:

=SVYHLEDAT(C6;ZVOLIT(B2;Prvni!A:R;Druhy!A:R;Treti!A:R);18;0)

V B2 je číslo listu (1,2,3, ...)citovat
#049362
Lugr
Takhle?
Příloha: xlsx49362_49357_test_promenna-nazev-listu.xlsx (16kB, staženo 57x)
citovat
#049364
avatar

lugr napsal/a:

Takhle?Příloha: 49362_49357_test_promenna-nazev-listu.xlsx (16kB, staženo 1x)


Super to je ono, děkuji 1citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Maticový vzorec

elninoslov • 6.7. 7:19

Maticový vzorec

MiraP • 5.7. 12:13

Maticový vzorec

elninoslov • 5.7. 0:07

Maticový vzorec

MiraP • 4.7. 22:26

Maticový vzorec

r13 • 4.7. 14:23

Maticový vzorec

lubo • 4.7. 14:11

Maticový vzorec

r13 • 4.7. 12:20