< návrat zpět

MS Excel


Téma: Svyhledat s proměnnou - název listu rss

Zaslal/a 5.1.2021 12:45

Ahoj,

mám 3 listy se stejnym formatem tabulek a potom list s názvem výkaz, na kterém bych potřeboval mít svyhledat s proměnným názvem listu, tzn, že v listu vykaz v bunce B2 vyberu první list a svyhledat by se mi změnil název listu ze kterého to hledá.
Např.
=VLOOKUP(C6;Druhy!A:R;18;0) po změně buňky B2 by byl =VLOOKUP(C6;Prvni!A:R;18;0)

Jde to nějak udělat nebo to excel neumi? Oblast pro svyhledat bude stale stejna, jen bude jiný list

Děkuji

Příloha: xlsx49357_test_promenna-nazev-listu.xlsx (16kB, staženo 9x)
Zaslat odpověď >

#049358
avatar
Pokud se jedná jen o 3 listy tak bych použil KDYŽ
=KDYŽ($B$2="Prvni"; SVYHLEDAT(C6;Prvni!A:R;18;0);KDYŽ($B$2="Druhy";SVYHLEDAT(C6;Druhy!A:R;18;0);SVYHLEDAT(C6;Treti!A:R;18;0)))citovat
#049359
avatar
Třeba:

=SVYHLEDAT(C6;ZVOLIT(B2;Prvni!A:R;Druhy!A:R;Treti!A:R);18;0)

V B2 je číslo listu (1,2,3, ...)citovat
#049362
Lugr
Takhle?
Příloha: xlsx49362_49357_test_promenna-nazev-listu.xlsx (16kB, staženo 39x)
citovat
#049364
avatar

lugr napsal/a:

Takhle?Příloha: 49362_49357_test_promenna-nazev-listu.xlsx (16kB, staženo 1x)


Super to je ono, děkuji 1citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

cislovanie riadkov

martin1 • 18.1. 20:47

Podmíněné formátování

Baja • 18.1. 18:55

VBA - načtení dat ze souboru s proměnným názvem

Fantasyk • 18.1. 14:29

zápis čísla fce suma

Stalker • 18.1. 13:17

smazání více obrázků

Zdenda-R • 18.1. 9:47

výpis adresáře

Milan-158 • 18.1. 9:31

zápis čísla fce suma

Josef-Sekan • 18.1. 9:26