< návrat zpět

MS Excel


Téma: Kumulovaný počet rss

Zaslal/a 27.1.2021 12:59

Zdravím, kdo by mohl prosím pomoci?

Pro někoho možná jednoduchá věc, ale mě se nedaří 5 .

Potřeboval bych kumulovaný počet, vytvořil jsem přes funkci KDyž....př. =když(C1=" ";" ";suma($C$1:C1))
Tohle funguje, každý dálší řádek je součet těch předchozích.

No kde jsem narazil, je, že mám různé kategorie čísel, potřeboval bych kumulovaný počet pro danou kategorii, zkoušel jsem přes funkci SUMIF nedaří se... Více v excel souboru v příloze.

Příloha: xlsx49594_kumulovany-pocet.xlsx (11kB, staženo 8x)
Zaslat odpověď >

Strana:  1 2   další »
#049595
avatar
=SUMIF($A$2:B2;A2;$B$2:B2)
Příloha: xlsx49595_49594_kumulovany-pocet.xlsx (11kB, staženo 6x)
citovat
#049596
avatar
zkuste
=SUMIFS($B$2:B2;$A$2:A2;A2)citovat
#049597
avatar
Perfektní děkuji, já si myslel, že to bude pro někoho prkotina 3citovat
#049598
Lugr
A pro lepší známku by to chtělo předělat toto:

=KDYŽ(B2=" "; " ";$B$2:B2)

na toto:

=KDYŽ(B2="";"";$B$2:B2)

1citovat
#049599
avatar

lugr napsal/a:

A pro lepší známku by to chtělo předělat toto:

=KDYŽ(B2=" "; " ";$B$2:B2)

na toto:

=KDYŽ(B2="";"";$B$2:B2)



5

Narazil jsem teď na druhý problém, použil sem funkci Sumif viz víše do mé tabulky, vše ok. Použil jsem filtr, abych si zobrazoval co potřebuji, ale vedle tabulky mám kontigenční tabulku a graf a další data. Pokud filtruji tabulku, ztrácí se ostatní buňky ze schovaných dat z filtru, např. graf se zmenší, kontingenční tabulka jde vidět jen z části atd.

Víte jak tomu zamezit?citovat
#049600
Lugr
No jasný, dejte si graf a KT na jiný list.citovat
#049601
avatar

Lugr napsal/a:

No jasný, dejte si graf a KT na jiný list.


To mě napadlo též, jen standart i pro zápis různých hodnot je mít vše na jednom listu.

Takže nelze nějak oddělit?citovat
#049602
Lugr
Tak potom už mě napadá jen vložit KT a graf nad filtrovanou tabulku, ale chápu, že to není úplně praktické.

Třeba má někdo jiný nějaké řešení.citovat
#049603
avatar
Vzhledem k tomu, že se neobtěžujete poslat soubor s tabulkou, KT a grafem, tak těžko plnohodnotně poradit.
Dotaz: na co máte KT a zároveň filtrujete zdrojovou tabulku?
Vždyť KT mám proto, abych si zobrazil co potřebuji, ne?citovat
#049604
avatar

Jiří497 napsal/a:

Vzhledem k tomu, že se neobtěžujete poslat soubor s tabulkou, KT a grafem, tak těžko plnohodnotně poradit.
Dotaz: na co máte KT a zároveň filtrujete zdrojovou tabulku?
Vždyť KT mám proto, abych si zobrazil co potřebuji, ne?


Není problém nahrát soubor, nebude fungovat KT a graf, zdrojová data jsou mimo...

KT používám pro vypsání počtu chyb do filtrované tabulky, kde pak zadávám nápravná opatření atd. Graf je jednoduché pareto. Pokud si vyfiltruji TOP 5 v tabulce, chci mít u toho zrovna graf.
Příloha: xlsx49604_sesit1.xlsx (195kB, staženo 5x)
citovat

Strana:  1 2   další »

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Spustit makro v určitý čas

Baja • 28.11. 20:11

Spustit makro v určitý čas

elninoslov • 28.11. 17:09

Spustit makro v určitý čas

Baja • 28.11. 12:51

Spustit makro v určitý čas

elninoslov • 28.11. 0:31

Spustit makro v určitý čas

Baja • 27.11. 22:22

Spustit makro v určitý čas

Anonym • 27.11. 22:20

Spustit makro v určitý čas

elninoslov • 27.11. 21:11