< návrat zpět

MS Excel


Téma: sčítání podle kritérií rss

Zaslal/a 14.4.2021 15:00

Ahoj,
mám tabulku

Sečíst Jméno 1 Jméno 2 Jméno 3
2 Roman Lukas Jirka
3 Adam Roman Jirka
10 Lukas Adam Roman

A potřebuju sečíst všechna čísla v prvním sloupci u kterých je ve 2., 3. nebo 4. sloupci jméno dané jméno.

Pro tento případ by to bylo Roman = 15, Lukas = 12, Jirka = 5 a Adam = 13

Klasická funkce sumifs mi nejde použít, protože počítá s tím, že musí být splněna všechny kritéria zatímco já bych potřebovala nějakou kombinaci funkcí SUMIFS a NEBO.

Řešení SUMIF(2.sloupec)+SUMIF(3.sloupec)+SUMIF(4.SLOUPEC) bych se chtěla vyhnout, protože reálně tam mám několik dalších kritérií a je to potom nepřehledný vzorec na 6 řádků.

Děkuju!

Zaslat odpověď >

#050420
elninoslov
=SUMPRODUCT($A$1:$A$3;--(COUNTIF(OFFSET($B$1:$D$1;ROW($A$1:$A$3)-1;);H1)>0))
=SOUČIN.SKALÁRNÍ($A$1:$A$3;--(COUNTIF(POSUN($B$1:$D$1;ROW($A$1:$A$3)-1;);H1)>0))
Příloha: xlsx50420_sumifor.xlsx (9kB, staženo 6x)
citovat
#050423
avatar
SUMA a SUMIFS taky funguje:

=SUMA(SUMIFS($A$1:$A$3;POSUN($A$1:$A$3;0;SLOUPEC($B$1:$D$1)-1);H1))citovat
#050439
avatar
Děkuju! funguje jak má.citovat
#050440
avatar
Omlouvám se...nenapsala jsem to hned, protože jsem předpokládala, že to zvládnu dodělat, ale nezvládnu.
Funkce =SOUČIN.SKALÁRNÍ($A$1:$A$3;--(COUNTIF(POSUN($B$1:$D$1;ROW($A$1:$A$3)-1;);H1)>0))
funguje jak má, ale ještě bych potřebovala přidat 2 kritéria, která musí být splněna viz. přiložený excel
Příloha: xlsx50440_wall_kriteria.xlsx (9kB, staženo 7x)
citovat
#050468
Fantasyk
opravdu nejblbější řešení 5, ale funguje 5 5 5citovat
#050469
elninoslov
=SUMPRODUCT($A$2:$A$5;--(COUNTIF(OFFSET($B$2:$D$2;ROW($A$2:$A$5)-2;);"Roman")*($E$2:$E$5="modrá")*($F$2:$F$5="obdelník")>0))
=SOUČIN.SKALÁRNÍ($A$2:$A$5;--(COUNTIF(POSUN($B$2:$D$2;ŘÁDEK($A$2:$A$5)-2;);"Roman")*($E$2:$E$5="modrá")*($F$2:$F$5="obdelník")>0))

V E4 nie je "modrá" ale "modrá " !

PS: V tom mojom prvom CZ ekvivalente som zabudol preložiť ROW na ŘÁDEK, a div sa svete, nikto sa nesťažoval 5citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

Najít data

Jiří497 • 12.5. 0:58

import xml dat do sešitu včetně označení sloupců

elninoslov • 12.5. 0:46

Najít data

elninoslov • 12.5. 0:40

Najít data

vikizaj • 11.5. 23:41

import xml dat do sešitu včetně označení sloupců

MilaF • 11.5. 23:20

VBA - automaticky posouvat vzorec v KT

Fantasyk • 11.5. 20:25

import xml dat do sešitu včetně označení sloupců

elninoslov • 11.5. 16:47