< návrat zpět

MS Excel


Téma: Funkce KDYŽ přes více listů rss

Zaslal/a 12.5.2021 15:27

Je možné použít funkci KDYŽ s odkazem na jiný list či přes více listů?

Zaslat odpověď >

#050654
avatar
Vyzkoušej a uvidíš. 9citovat
#050655
avatar
Děkuji pane Rejpal za velkolepou odpověď. Jen se trochu minula cílem, ježto jsem to přirozeně zkoušel, ale nešlo mi to - jen v jednom listu...
Nějaký další návrh?citovat
#050656
avatar
Jestli jste to zkoušel, tak jste ten pokus mohl vložit. Ne proto, abychom se smáli, ale můžeme ukázat kde jste udělal chybu.
=KDYŽ (List2!A1 = 5;1;0)citovat
#050657
elninoslov
Myslíte 3D vzorec? Teda ak zoberiem príklad od Jiřího, tak chcete zistiť, či sa A1 vo všetkých listoch rovná 5? Potom, keďže funkcia IF/KDYŽ nepodporuje priamo 3D odkazy, dal by sa použiť test vynásobenia čísel v A1 vo všetkých listoch a následné porovnanie s N-tou mocninou čísla 5. Prázdne A1 neberie do úvahy. Problém je, že daný súčin sa dá dosiahnuť aj inými číslami:
=IF(PRODUCT(List2:List5!A1)=5^COUNT(List2:List5!A1);1;0)
=KDYŽ(SOUČIN(List2:List5!A1)=5^POČET(List2:List5!A1);1;0)

alebo porovnať min a max v bunkách A1 v listoch. Musí byť vždy 5. Prázdne rovnako neberie do úvahy:
=IF(AND(MAX(List2:List5!A1)=5;MIN(List2:List5!A1)=5);1;0)
=KDYŽ(A(MAX(List2:List5!A1)=5;MIN(List2:List5!A1)=5);1;0)

V 3D dotaze určujete prvý a posledný názov listu v rozsahu listov.
Ak chcete čokoľvek iné, Váš popis nie je dostatočný, a je potreba popis rozšíriť a zároveň priložiť prílohu s príkladom toho čo máte, a čo má byť výsledkom.citovat
#050665
avatar
Moc děkuji za vaše odpovědi. Zatím mně to však nepomohlo, a tak tedy vložím i soubor kde to zkouším. V části „NOTES“ je pak další vysvětlení. A sem vkládám přímo vzorec, který jsem zkusil.
funkční vzorec - aplikace na stejném listu:
=KDYŽ(SUM_JK_LK>0;L19;"inactive")
ne-funkční vzorec - aplikace na jiném listu (s odkazem na list):
=KDYŽ(JANUARY!SUM_JK_LK >0;"inactive")
Příloha: xls50665_cp-part-to-review.xls (138kB, staženo 6x)
citovat
#050668
elninoslov
Pre všetky Def. názvy v JANUARY máte rozsah "Zošit". Takže ich voláte iba názvom Def. názvu. Na rozdiel od toho všetky okrem JANUARY majú Def. názvy s rozsahom pre daný list, takže ich voláte napr. FEBRUARY!SUM_JK_LK. Zrovnajte si rozsahy Def. názvov a je to. (musíte ich zmazať a vytvoriť znovu so želaným Rozsahom)citovat
#050670
avatar
Moc moc děkuju za odpověď. Udělám jak navrhujete, a pak dám vědět o výsledku 1citovat
#050693
avatar
Jiný způsob než smazání není? Nějaké automatické vrácení adres? Kdybych věděl, že vrácení je takové krkolomné, tak bych tam ty názvy nezadával, čekal bych nějaké snadné vrácení…citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

cislovanie riadkov

martin1 • 18.1. 20:47

Podmíněné formátování

Baja • 18.1. 18:55

VBA - načtení dat ze souboru s proměnným názvem

Fantasyk • 18.1. 14:29

zápis čísla fce suma

Stalker • 18.1. 13:17

smazání více obrázků

Zdenda-R • 18.1. 9:47

výpis adresáře

Milan-158 • 18.1. 9:31

zápis čísla fce suma

Josef-Sekan • 18.1. 9:26