< návrat zpět

MS Excel


Téma: Zápis vzorce do buňky pomocí VBA rss

Zaslal/a 14.5.2021 13:33

Dobré odpoledne,

poradil by mi prosím někdo, jaký VBA kód odpovídá níže uvedenému vzorci, který mám umístěný v buňce A2?

=KDYŽ(NEBO(D2="";JE.PRÁZDNÉ(E2));"";D2*E2)

zkoušel jsem níže uvedené, ale excel vždy hlásí chybu (run-time error '1004': Application-defined or object-defined error)

Range("A2").FormulaLocal = "=IF(OR(D2="";ISBLANK(E2));"";D2*E2)"

díky moc

Zaslat odpověď >

#050673
Lugr
Range("A2").Formula = "=IF(OR(D2="""",ISBLANK(E2)),"""",D2*E2)"citovat
#050674
avatar
funguje skvěle, díky moccitovat
#050675
avatar
Nebo takto:Range("A2").FormulaLocal = "=KDYŽ(NEBO(D2="""";JE.PRÁZDNÉ(E2));"""";D2*E2)"citovat
#050784
Fantasyk
Vždy když se zapisují ve VBA uvozovky tak se musí napsat 2xcitovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Tlac s farebneho

ivana1 • 19.6. 22:16

GRAF teploty

Scraper • 18.6. 15:34

Vyhledat dnešní datum když je číslo jako text

veny • 17.6. 13:56

Vyhledat dnešní datum když je číslo jako text

Ontik • 17.6. 12:07

Zaokrouhlování

lubo • 17.6. 12:03

Zaokrouhlování

JoKe • 14.6. 15:19

Zaokrouhlování

Mirek-Kraus • 14.6. 13:52