< návrat zpět

MS Excel


Téma: MIN, MAX a PRŮMĚR dle kritéria rss

Zaslal/a 1.6.2021 21:10

Zdravím vás exceloví mágové, mám takový problém. Mám datumy, které se budou dále doplňovat a vedle toho hodnoty o teplotě, vlhkosti a rosném bodu. Potřeboval bych zjistit minima, maxima a průměry daných dnů. Nějak mi to nejde dát do kupy. Pomůžete, prosím? Děkuji moc

Příloha: xlsx50773_data.xlsx (59kB, staženo 4x)
Zaslat odpověď >

#050774
Lugr
Může být?
Příloha: xlsx50774_data.xlsx (63kB, staženo 7x)
citovat
#050775
avatar
Netušil jsem, že existuje funkce MINIFS, MAXIFS. Je to perfektní, děkuji moc :)citovat
#050777
elninoslov
Áno, v nových Office to je, v starších treba nahradiť maticovým vzorcom.citovat
#050778
Lugr
Zase máš pravdu elninoslov, zkoušel jsem to na MS Office 2016 a nejde to. Tak raději ještě maticově pro starší verze.
Příloha: xlsx50778_data.xlsx (64kB, staženo 5x)
citovat
#050785
avatar
No ale teď se dívám, že nesedí ty průměry. Průměr je myšleno NE průměr mezi max a min, ale průměr z celého dne. Zkoušel jsem SUMIFS/COUNTIFS, ale nějak mi to nepočítá :( Děkuji za pomoccitovat
#050787
elninoslov
No tak dajte priemer všetkých hodnôt (maticovo):
=AVERAGE(IF(data!B:B=A3;data!E:E))
=PRŮMĚR(KDYŽ(data!B:B=A3;data!E:E))

alebo väčšia konštrukcia bez matice a s kontrolou iba skutočne zaplnených oblastí, nie celých stĺpcov (pretože dátumy sú zoskupené):
=AVERAGE(OFFSET(data!$E$2;MATCH(A3;OFFSET(data!$B$3;;;COUNT(data!B:B));0);;COUNTIF(OFFSET(data!$B$3;;;COUNT(data!B:B));A3)))
=PRŮMĚR(POSUN(data!$E$2;POZVYHLEDAT(A3;POSUN(data!$B$3;;;POČET(data!B:B));0);;COUNTIF(POSUN(data!$B$3;;;POČET(data!B:B));A3)))

Prípadne to zjednodušiť tak, že sa dá aspoň ten jeden OFFSET do def. názvu OBLAST
=OFFSET(data!$B$3;;;COUNT(data!B:B))
=POSUN(data!$B$3;;;POČET(data!B:B))

a následne
=AVERAGE(OFFSET(data!$E$2;MATCH(A3;OBLAST;0);;COUNTIF(OBLAST;A3)))
=PRŮMĚR(POSUN(data!$E$2;POZVYHLEDAT(A3;OBLAST;0);;COUNTIF(OBLAST;A3)))

prípadne obdobne ...citovat
#050788
avatar
Díky, bomba, funguje to. Super :)citovat
#050789
avatar
Dotaz:
Je nějaký důvod, proč nepoužít kontingenční tabulku?

Řeší totéž na pár kliknutí.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Vodorovný teploměr v buňce

GeorgeK • 1.12. 12:26

Vodorovný teploměr v buňce

elninoslov • 1.12. 10:21

Vodorovný teploměr v buňce

Stalker • 1.12. 10:01

Vodorovný teploměr v buňce

GeorgeK • 1.12. 9:15

Spustit makro v určitý čas

Baja • 28.11. 20:11

Spustit makro v určitý čas

elninoslov • 28.11. 17:09

Spustit makro v určitý čas

Baja • 28.11. 12:51