< návrat zpět

MS Excel


Téma: Priradenie cisla v bunke do absolutnej cesty vo rss

Zaslal/a 4.6.2021 11:24

Zdravim, je moznost v ramci vzorcu WEEKDAY($N$1:$N$30;2) priradit $N$1:$N$30 - miesto cisla $N$30 nieco z napriklad D2, kde sa bude toto cislo menit v zavislosti na pocet cisiel pre ratanie AVG...

mam vzorec:
=AVERAGE(IF(WEEKDAY($N$1:$N$30;2)=C5;$M$1:$M$30))
Ale uzivatel zmeni cislo napriklad na 180 a uz by som musel zmenit aj ten vorec na
=AVERAGE(IF(WEEKDAY($N$1:$N$180;2)=C5;$M$1:$M$180))
Ako docielit toho, ze mi tam bude brat to, co je v bunke D2? Potrebujem to nejako zautomatizovat
Diky

Zaslat odpověď >

#050797
elninoslov
Cez OFFSET/POSUN sa dá nastaviť veľkosť oblasti (3. a 4. parameter), alebo INDIRECT/NEPŘÍMÝ.ODKAZ.
Príklad:
=AVERAGE(IF(WEEKDAY(OFFSET($N$1;;;D2);2)=C5;OFFSET($M$1;;;D2)))
=PRŮMĚR(KDYŽ(DENTÝDNE(POSUN($N$1;;;D2);2)=C5;POSUN($M$1;;;D2)))
citovat
#050799
avatar

elninoslov napsal/a:

Cez OFFSET/POSUN sa dá nastaviť veľkosť oblasti (3. a 4. parameter), alebo INDIRECT/NEPŘÍMÝ.ODKAZ.
Príklad:
=AVERAGE(IF(WEEKDAY(OFFSET($N$1;;;D2);2)=C5;OFFSET($M$1;;;D2)))
=PRŮMĚR(KDYŽ(DENTÝDNE(POSUN($N$1;;;D2);2)=C5;POSUN($M$1;;;D2)))


Urobil som to podobne nakoniec, Cez Name Manager som si definoval meno a zadal tam aby som videl, ze kolko je teda tych riadkov nakoniec (generujem tam spill vzorec StockHistory):

=OFFSET(data!$A$1;0;0;COUNTA(data!$A:$A);1)

a potom priamo na tu AVG:
=IFERROR(AVERAGE(IF(WEEKDAY(datum;2)=C9;peniaze));"no data")

Kuknem este na to vase, tiez vypada dobre
Dikycitovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Spustit makro v určitý čas

Baja • 28.11. 20:11

Spustit makro v určitý čas

elninoslov • 28.11. 17:09

Spustit makro v určitý čas

Baja • 28.11. 12:51

Spustit makro v určitý čas

elninoslov • 28.11. 0:31

Spustit makro v určitý čas

Baja • 27.11. 22:22

Spustit makro v určitý čas

Anonym • 27.11. 22:20

Spustit makro v určitý čas

elninoslov • 27.11. 21:11