< návrat zpět

MS Excel


Téma: Sečíst sloupec od 4 řádku rss

Zaslal/a 29.7.2021 9:59

Ahoj,
poradí mě někdo jak sečíst celí sloupec od 4 řádku níže?

Pro příklad: Jde o to že se někdy řádky přidávají a zase odstraňují a tak se funkce =SUMA(A4:A10000) kterou mám ve A3 se mění na ....A9999 nebo zase .....A10001 a protože mám i nějaká data v A1 a A2 tak nejde použít =SUMA(A:A)

Tak jestli nejde něco jako =SUMA(A4:A) co mi nefunguje. Prostě sečíst vše od 4 řádku níže aď 100 nebo 100000 řádek.

Děkuji za rady

Zaslat odpověď >

#051065
avatar
Jednou z možností je využití odkazování na oblast přes funkce NEPŘÍMÝ.ODKAZ a ODKAZ.
P.

Například:
=SUMA(NEPŘÍMÝ.ODKAZ(ODKAZ(4;1;4) & ":" & ODKAZ(10000;1;4); PRAVDA))citovat
#051066
avatar

Janinka88 napsal/a:

Pro příklad: Jde o to že se někdy řádky přidávají a zase odstraňují a tak se funkce
=SUMA(A4:A10000)
kterou mám ve A3 se mění na ....A9999 nebo zase .....A10001 a protože mám i nějaká data v A1 a A2 tak nejde použít


a nestačilo by zamknout buňky ve vzorci?
=SUMA($A$4:$A$10000)citovat
#051067
avatar
@Pavlus děkuji čekala jsem to jednoduší 5

@Veny
Zamknout je nemohu, přidávat řádky a občas odstraňovat je potřeba.

Jestli by zjednodušilo potřebuji sečíst hodnoty v celém sloupci krom prvních tří řádků.

Data se zapisují pod sebe a protože se někdy jeden řádek zapomene zapsat, tak si ho tam vložíme a vše pod ním se posune. To v tomto případě nevadí, protože se funkce přepíše o jedno číslo více. Problém ale nastane když zjistíme že je tam jeden řádek (údaj) vložen dvakrát, tak tento řádek odstraníme (jen smazáním dat by nežádoucí vznikla mezera a muselo by se vše pod překopírovat víše)

zatím to je řešeno že jsem si změnili =SUMA(A4:A100) na =SUMA(A4:A10000) kam snad data nedopíšeme, ale kdyby náhodou 1 protože již dnes je po smazání několik řádku toto číslo zmenšeno o 2 (Více krát řádku odstraňujeme než přidáváme). Tak aby se na to nemuselo pamatovat a přesáhlo by se zmíněný řádek že je třeba funkci přepsat na vetší číslo.citovat
#051068
avatar
=SUMA(A:A)-SUMA(A1:A3)
alebo
=SUMA(POSUN(A4;;;ŘÁDKY(A:A)-3))citovat
#051069
avatar

marjankaj napsal/a:

=SUMA(A:A)-SUMA(A1:A3)
alebo
=SUMA(POSUN(A4;;;ŘÁDKY(A:A)-3))


Super, druhé zmíněné funguje perfektně.
Děkuji

První má problém že nemůže být v 3 řádku stejným sloupcicitovat
#051070
avatar
A nebo naformátovat jako "Tabulku"

=SUMA(Tabulka1[Sloupec1])citovat
#051071
avatar
@Janinka88: Vzhledem k tomu co píšete, a za předpokladu, že ve sloupci "A" nebude nikdy nic navíc, co nechcete sčítat, a za předpokladu, že se nebudou odstraňovat první 3 řádky, tak stačí prosté (ve verzi Excelu "xlsx"):
=SUMA(A4:$A$1048576)Díky absolutnímu adresování (přes $) úplně poslední buňky listu se ani při přidávání/odstraňování řádků 4 až 1048576 v součtovém vzorečku nic nemění...

P.citovat
#051237
avatar
skúste toto
=SUM(X4:INDEX(X:X;ROW()-1))citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Kumulace listů do jednoho listu

Lugr • 28.9. 11:24

Kumulace listů do jednoho listu

veny • 27.9. 11:23

skenovani a vyhledavani a oznaceni v tabulce

elninoslov • 24.9. 23:11

Kumulace listů do jednoho listu

MonikaV • 24.9. 17:18

skenovani a vyhledavani a oznaceni v tabulce

djph • 24.9. 13:44

Sečíst sloupec od 4 řádku

madar5 • 23.9. 8:32

Ověření dat

lubo • 22.9. 11:25