< návrat zpět

MS Excel


Téma: Súčet čísel v zozname od zadu rss

Zaslal/a 25.11.2021 8:38

Potreboval by som radu. Mám zoznam (A9 - ZZ9) zatiaľ je to len po Y, a potreboval by som pomôcť so súčtom.
Požiadavka znie, že potrebujem spočítať daný počet posledných mesiacov (koľko ich je sa udáva v zložke G5).
Do toho zoznamu budem však kazdý mesiac dopisovať a ja si určím koľko posledných mesiacov (ich hodnoty) sa má spočítať.
Od predu to viem (cez INDEX), bohužiaľ z druhej strany to neviem.
Velikánska vďaka za odpoveď.
Kajo

Příloha: xlsx51585_111.xlsx (14kB, staženo 3x)
Zaslat odpověď >

#051589
elninoslov
=SUM(OFFSET(B9;;COUNTA(8:8)-G5;;G5))
=SUMA(POSUN(B9;;POČET2(8:8)-G5;;G5))
citovat
#051591
avatar
Elninoslov veľmi pekne ďakujem za odpoveď pomohla.
Ešte by som potreboval dať nejakú podmienku, ak by bola hlavička vyplnená už na celé mesiace, ale hodnoty by neboli tak to počíta aj s tími prázdnymi hodnotami.
Napr. jul - dec je prázdny a dam počítať posledných 12 mesiacov tak ráta aj nulové hodnoty od jul - dec. Dá sa to nejak ošetriť????
S pozdravom
Kajcocitovat
#051593
elninoslov
=SUM(OFFSET(B9;;COUNT(9:9)-G5;;G5))
=SUMA(POSUN(B9;;POČET(9:9)-G5;;G5))

Ale buďte si v oboch prípadoch vedomý toho, že sa musí jednať o súvisle vyplnené bunky. Ak niekde bude nevyplnený mesiac, tak to bude rátať zle. V takomto prípade bude vzorec nie s použitím COUNT/POČET ale s LOOKUP/VYHLEDAT.
=SUM(OFFSET(B9;;LOOKUP(2;1/(9:9<>"");COLUMN(9:9))+1-G5;;G5))
=SUMA(POSUN(B9;;VYHLEDAT(2;1/(9:9<>"");SLOUPEC(9:9))+1-G5;;G5))

Prípadne (a to bude najzložitejšie) ak by sa mali spočítať iba vyplnené mesiace. Teda pri 3 prázdnych mesiacoch niekde v priebehu, by sa malo zrátať obdobie 15 mesiacov. Na to sa ešte pozriem, ak bude treba...citovat
#051595
avatar
OK veľmi pekne ďakujem takto to zatiaľ stačí.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Vodorovný teploměr v buňce

GeorgeK • 1.12. 12:26

Vodorovný teploměr v buňce

elninoslov • 1.12. 10:21

Vodorovný teploměr v buňce

Stalker • 1.12. 10:01

Vodorovný teploměr v buňce

GeorgeK • 1.12. 9:15

Spustit makro v určitý čas

Baja • 28.11. 20:11

Spustit makro v určitý čas

elninoslov • 28.11. 17:09

Spustit makro v určitý čas

Baja • 28.11. 12:51