< návrat zpět

MS Excel


Téma: Chybné řazení ve filtrované oblasti rss

Zaslal/a 3.12.2021 14:10

Zdravím pánové a dámy,

potřebuji poradit jelikož mi to hlava nebere a netuším proč řazení u mé filtrované tabulky nepracuje správně neboli podle mých představ 5 .
Podotýkám, že jsem chtěl přiložit ještě jednu předchozí verzi tabulky před změnou, ve které řazení bylo funkční, ale jaksi mohu přiložit jen jeden soubor. Z ní by to bylo pravděpodobně přehlednější

Tudíž se to budu snažit vysvětlit 1
vzorec ve sloupci A mi zajišťuje generování kódového zápisu dokumentu na základě:
sloupce B,D jsou vstupem pro zadání číselné hodnoty
sloupec F určuje písemné zařazení dokumentu na základě podmínek
zobrazování celého zápisu je podmíněn ve sloupci E
v buňce F1 zadávám číselné pořadí měsíce, pro který chci dané entity zvýraznit -> dále filtrovat a pracovat 1

Ve sloupci A je pravděpodobně problémový vzorec jelikož nedávno jsem změnil znění vzorce ve sloupci A z
=KDYŽ(JE.PRÁZDNÉ($E2);"";IFERROR(KDYŽ(NAJÍT("o";$F2);"M";"");"")&"KT"&HODNOTA.NA.TEXT($D2;"RRMMDD")&"-"&$B2)

na

=KDYŽ(JE.PRÁZDNÉ(KT!$E2);"";IFERROR(KDYŽ(A(ČÁST(KT!$F2;1;1)="o";COUNTIF(oblastVYHLEDAVANI;KT!$F2)=0);"M";"");"")&"KT"&HODNOTA.NA.TEXT(KT!$D2;"RRMMDD")&"-"&KT!$B2)

byla přidána dynamická oblast určená názvem a ta mi zajišťuje hlídání rozdílného znění písemného řazení zápisu v případě že je entita uvedená v listu HARMONOGRAM pro mnou vybraný měsíc -> oblastVYHLEDAVANI

a teď ta nesrovnalost 8
jelikož s tabulkou intenzivně pracuji jen na konci měsíce všiml jsem si, že když dám např. filtraci jen některého měsíce tak vzorec pracuje správně. Ale jakmile zadám např. řadit podle entity ve sloupci F vzorec se rozhodí a výsledný kódový zápis je špatný.

Neví někdo čím to je? Případně jak to ošetřit?
Jelikož smíšené vzorce ve svých tabulkách používám velmi často a i dynamické oblasti -> představa, že se mi to stalo/stane někde jinde je děsivá 7

Děkuji.

Zaslat odpověď >

#051629
elninoslov
Žiadna príloha tu nie je. Ak je to XLSM, musíte ho zabaliť do ZIP/RAR. Ak je príliš veľká, orežte rozumne data na <300 KB (nepamätám si presne veľkostný limit).citovat
#051630
avatar
Zde zmiňovaný soubor bohužel rozdělený kvůli limitům do dvou souborů .rar (nefunguje jeden bez druhého 8 )

sbaleno aplikaci WinRAR
Příloha: rar51630_sortingissue.part01.rar (256kB, staženo 3x)
citovat
#051631
avatar
2. část
Příloha: rar51631_sortingissue.part02.rar (141kB, staženo 3x)
citovat
#051633
elninoslov
1. Odstráňte maticovosť toho vzorca. To bude kameň úrazu.
Ďalej už iba poznámky:
2. Dúfam, že nezoraďujete aj list HARMONOGRAM.
3. Veľkosť súboru je daná "použitím" milióna riadkov. Stavím ľavú topánku, že toľko riadkov nepoužívate.
4. Vzorec v definovanom názve oblastVYHLEDAVANI divne používa zbytočné množstvo MATCH/POZVYHLEDAT.
5. Vzorec v A neošetruje možnosť nesprávneho zadania čísla mesiaca, treba použiť inak to IFERROR.
6. Ak má súbor použiť ktokoľvek s iným ako CZ Office, treba nahradiť
HODNOTA.NA.TEXT($D2;"RRMMDD")
za
ZPRAVA(ROK($D2);2)&HODNOTA.NA.TEXT($D2;"MMDD")
Lebo "RRMMDD" pozná iba CZ. Také SK, EN to má "YYMMDD"
7. maličká úprava PF
Příloha: xlsx51633_sortingissue2.xlsx (25kB, staženo 5x)
citovat
#051639
avatar
Děkuji mockrát 1

ad 2) řadím, ale jen když přidám novou entitu do harmonogramu. Musí být seřazeny podle sloupce C od 1 do 12 jinak by to nefungovalo 4
ad 3) určitě by jste vyhrál, ale kde jste vzal že používám jich tolik? formátování mám jen na ohraničenou malou oblast a data jsou taky jen ve viditelné oblasti
ad 4) kámen úrazu celého problému->harakiri vzorec (už ani nevím jak jsem k němu došel)
ad 5) aplikuji ověření dat na buňku volbyMěsíce. Funkce A mi ošetřuje jen případ výskytu entity počínající písmenem "o" v harmonogramu pro daný měsíc, podmínka se neuplatňuje na jinak definované entity.
ad 6) naštěstí je to jen pro mou potřebu 5, ale děkuji Vaše formulace, je univerzálnější a elegantnější
ad 7) omlouvám se, ale nepostřehl jsem, zkratka PF mi bohužel nic neříká.

Ještě jednou díky.citovat
#051640
elninoslov
Som len na mobile. Tak len zbežne. PF je Podmienené formátovanie. Milión radkov som si všimol tuším na posuvníku. Normálne sa tam posuvníkom nedostanete. Ako potvrdenie je veľkosť suboru. Kameň úrazu nieje Definovaný názov, ale ten maticový vzorec v stĺpci A.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

odskok v makru jinam

PavDD • 13.5. 9:03

odskok v makru jinam

Barth • 13.5. 7:25

číslování

Kalous • 12.5. 20:50

odskok v makru jinam

marjankaj • 12.5. 20:43

číslování

r13 • 12.5. 20:23

číslování

r13 • 12.5. 20:19

číslování

Kalous • 12.5. 19:46