< návrat zpět

MS Excel


Téma: Podmíněné formátování rss

Zaslal/a 14.1.2022 21:18

Ahoj excelenti, prosím o radu či nakopnutí. Mám tabulku a potřeboval bych tu zakomponovat následující podmínky:
1) když jsou "dnes" dny: pondělí, úterý, středa nebo čtvrtek, tak se musí obarvit následující den (dnes+1)
2) když je pátek, tak se obarví sobota, neděle a pondělí.
3) podmínky se svátky jsou složitější, tak případně doplním, zatím by stačilo toto. Nevím si s tím rady, zkouším vzorečky:
=KDYŽ(DNES()=DENTÝDNE(DATUM(rok;$B$2;DEN(DNES()));11)=5;A(DNES()+1;DNES()+2;DNES()+3);DNES()+1)
nebo různé kombinace funkce KDYŽ, ale nejde mi to.
Děkuji za případné příspěvky, B

Příloha: xlsx51885_podm.format.xlsx (23kB, staženo 15x)
Zaslat odpověď >

#051886
avatar
neodladěno mám E2007, který nepodporuje použité parametry u DENTÝDNE, možná je bude nutné poupravit.

=DENTÝDNE(DNES();16)<4 formát nenastaven ukončit
=DATUM(rok;$B$2;C$2)-DNES()=1 nastavit formát
=A(DENTÝDNE(DNES();11)=5; DENTÝDNE(DATUM(rok;$B$2;C$2);16)<3 nastavit formát

Pro skrytí posledních dnů v kratších měsících by mělo stačit
=MĚSÍC(DATUM(rok;$B$2;C$2))<>$B$2 skrýtcitovat
#051887
avatar
Děkuji moc, zkusím dnes či zítra až se k tomu dostanu. Bcitovat
#051899
avatar
Zdravím, pro dnešek to funguje, uvidíme jak v pátek :)
No a pak bych tam ještě potřeboval zakomponovat SVÁTKY, ale to bude trošku složitější.
Obecně potřebuji, aby se označovalo, když zítra bude svátek nebo víkend, tak označit víkend nebo svátek plus 1 pracovní den.
Šlo by to, prosím? Děkuji moc, už mám z těch podmínek hlavu v pejru :)citovat
#051901
avatar
Pokud to chápu, tak
Pokud je pro nějaké datum předchozí pracovní den dnes, tak vybarvit:

=WORKDAY(DATUM(rok;$B$2;C$2);-1;svátky)=DNES()

(vč. svátků - podle stejné logiky)citovat
#051917
avatar
Děkuji moc všem, co přispěli, jde to (zatím) skvěle, palec nahoru :)citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Makro na upozornění události

parkovec • 21.5. 15:22

Makro na upozornění události

elninoslov • 21.5. 2:38

Sloučení dat dvou sešitů

Scraper • 20.5. 7:55

Sloučení dat dvou sešitů

Stalker • 19.5. 23:06

Makro na upozornění události

parkovec • 19.5. 21:07

plynulá pomalá změna barvy

PavDD • 19.5. 13:47

plynulá pomalá změna barvy

veny • 19.5. 13:23