< návrat zpět

MS Excel


Téma: Průměr součtu - více podmínek rss

Zaslal/a 8.3.2022 8:27

Hezký den.
Potřeboval bych od Vás pomoc se vzorcem pro výpočet průměru. S jednou podmínkou ve sloupci mě to pracuje, ale nedokáží dát dvě podmínky v jednom sloupci.
Víc v přiloženém souboru.
Předem děkuji za pomoc.

Edit: Zapoměl jsem dodat, že průměr je z hodnot větších než 0,5.

Příloha: xlsx52248_prumer.xlsx (47kB, staženo 18x)
Zaslat odpověď >

Strana:  1 2   další »
#052249
avatar
Řešením je funkce AVERAGEIFS.
P.citovat
#052250
avatar

Pavlus napsal/a:

Řešením je funkce AVERAGEIFS.
P.

Kde dělám chybu?
Příloha: xlsx52250_prumer.xlsx (47kB, staženo 16x)
citovat
#052251
avatar
Tam, že zadávaš podmienku, že v stĺpci B je údaj rovný nule a zároveň rovný piatimcitovat
#052252
avatar
Jak mám vložit tu druhou podmínku pro sloupec "B"?
Pavlus tvrdil, že je na to funkce AVERAGEIFS.citovat
#052253
avatar
Já bych to viděl na kombinaci sumifs a countifs.
Sečíst si zvlášť hodnoty pro podmínku 0 a pro podmínku 5. Sečíst a podělit počtem prvků

(SUMIFS (pro B=0) + SUMIF (pro B=5)) / (COUNTIFS (pro B=0) + COUNTIFS (pro B=5))
=(SUMIFS(A4:A2884;A4:A2884;">0,5";B4:B2884;0;C4:C2884;16)+SUMIFS(A4:A2884;A4:A2884;">0,5";B4:B2884;5;C4:C2884;16))/(COUNTIFS(A4:A2884;">0,5";B4:B2884;0;C4:C2884;16)+COUNTIFS(A4:A2884;">0,5";B4:B2884;5;C4:C2884;16))
Příloha: xlsx52253_52250_prumer.xlsx (48kB, staženo 10x)
citovat
#052254
avatar
Ano je na to AVERAGEIFS, ale len pokiaľ jej správne zadáš argumenty. Vypočíta priemer z položiek, u ktorých platia všetky uvedené podmienky. Súčasne. Ty si tam zadal nelogickú podmienku.
Riešenie: zaveď si pomocný stĺpec, ktorý Ti vráti napr jednotku u tebou požadovaných podmienok a potom stačí priemer s jedinou podmienkou: že v pomocnom stĺpci bude jednotka. V takom prípade pre jednu podmienku už stačí AVERAGEIF (pozor, poradie argumentov je odlišné od AVERAGEIFS)

Napr do D4 napíšeš podmienku: =KDYŽ(A(A4>0,5;NEBO(B4=0;B4=5);C4=16);1;0)vyplníš nadol a potom do I2 napíšeš:
=AVERAGEIF(D4:D2884;1;A4:A2884)
Analogicky pre I3citovat
#052257
avatar
To Jiří497
Moc děkuji. 2citovat
#052258
avatar
To r13
Také děkuji. 3citovat
#052259
avatar
Diky 9citovat
#052260
avatar
Taky jde použít průměr:

=PRŮMĚR(FILTER(A4:A2884;--(A4:A2884>0,5)*(--(B4:B2884=E2) + (B4:B2884=F2))*(C4:C2884=G2)))citovat

Strana:  1 2   další »

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Porovnávací Tabulka

lubo • 25.6. 10:09

Porovnávací Tabulka

Jirka78 • 25.6. 9:21

Porovnávací Tabulka

Jess • 25.6. 6:46

rozlisna tlac excelu na 2 pc

elninoslov • 24.6. 23:28

Porovnávací Tabulka

elninoslov • 24.6. 23:26

Porovnávací Tabulka

Jess • 24.6. 22:46

rozlisna tlac excelu na 2 pc

Michalko • 24.6. 7:04